<html>
    <head>
      <base href="https://bugs.sourcemage.org/" />
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - deprecation of gnupg (casting gnupg-2.2) leaves cleanse confused with gnupg dependencies"
   href="https://bugs.sourcemage.org/show_bug.cgi?id=16113">16113</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>deprecation of gnupg (casting gnupg-2.2) leaves cleanse confused with gnupg dependencies
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>Codex
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>test grimoire
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>x86
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>Linux
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>normal
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>P2
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>crypto
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>sm-grimoire-bugs@lists.ibiblio.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>sobukus@sourcemage.org
          </td>
        </tr>

        <tr>
          <th>Classification</th>
          <td>Unclassified
          </td>
        </tr></table>
      <p>
        <div>
        <pre>I started with stable-0.62 chroot and upgraded to test. After various
issues (lib soname changes, sorcery being incompatible with bash 5.0), I
am surprised by cleanse complaining about gnupg dependencies after
gnupg has been dispelled in favour of gnupg-2.2. First was
smgl-archspecs. It was fixed by re-casting. Then followed bzip2, so
I presume it is a common pattern:

# cleanse
Fixing packages...
Pass 1 (bad lines)
Pass 2 (non-existant spells)
Pass 3 (duplicate entries)
Done fixing packages.
Delinting...
Pass one (malformed depends lines)
Pass two (stale depends entries)
    0 bad lines, 460 good lines in your depends file.
Pass three (duplicate depends entries)
Pass four (duplicate sub_depends entries)
Pass five (stale sub_depends entries)
    0 bad lines, 8 good lines in your sub_depends file.
Pass six (duplicate trigger entries)
Pass seven (stale trigger entries)
    0 bad lines, 34 good lines in your trigger file.
Delint done.
Cleaning log files...
Pruning...
bzip2 needs gnupg (required).
    (0)  Ignore
    (1)  Dispel bzip2
    (2)  Cast gnupg

I'll just do a rebuild now, but it would probably be better to find a proper
fix.</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>