Skip to Content.
Sympa Menu

sm-discuss - Re: [SM-Discuss] Detection of GNU C++ compiler hangs when compiling gcc 4.3.0

sm-discuss AT

Subject: Public SourceMage Discussion List

List archive

Chronological Thread  
  • From: "Javier Vasquez" < AT>
  • To: "SM, Discuss" <sm-discuss AT>
  • Subject: Re: [SM-Discuss] Detection of GNU C++ compiler hangs when compiling gcc 4.3.0
  • Date: Sun, 25 May 2008 11:47:08 -0600

On Sun, May 25, 2008 at 11:32 AM, Javier Vasquez < AT> wrote:
> Hi,
> On a laptop under test grimoire, for which I haven't run "sorcery -s"
> even before the gcc 4.3.0 release on test, I decided to go ahead and
> perform "sorcery -s" as I did with another box some time back.
> However at some point while compiling one of the gcc/g++ components
> the process completely froze on one of the ./configure's:
> checking whether we are using the GNU C++ compiler...
> Well, then I tried re-casting gcc, and I always get immediately after
> trying casting the same error. So, after some debug, I know that
> what's trying to get executed is $ac_complie, which at the moment of
> running is:
> $CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5
> But that fails with :
> g++: unrecognized option '-mtune=generic'
> This comes from:
> (eval $ac_compile) 2>conftest.er1 ~ line 3904 of the ./configure file...
> Why is this? How can it be overcome? It looks like I'm stuck, :(.

Bad additional thing is that for some reason I can't downgrade neither
gcc, nor g++, their cache's are not available, well, the gcc one is
available but for veersion 4.3.0, while the g++ one is gone, :(. I
supposed the 4.2.8 version ofboth spells were available, to resurrect
these 2 guys, but they're not...


Archive powered by MHonArc 2.6.24.

Top of Page