Skip to Content.
Sympa Menu

sm-discuss - Re: [SM-Discuss] HAL strangeness

sm-discuss AT

Subject: Public SourceMage Discussion List

List archive

Chronological Thread  
  • From: "Ethan Grammatikidis" <eekee57 AT>
  • To: sm-discuss AT
  • Subject: Re: [SM-Discuss] HAL strangeness
  • Date: Mon, 20 Apr 2009 03:32:18 +0100

On Sun, 19 Apr 2009 11:29 +0200, "Treeve Jelbert" <treeve AT>
> My linux system has been out of commission for a couple of days.
> Everything
> would freeze when entering run level 5.
> Eventually I found an error message from xorg, refering to HAL. I then
> discovered that hald had crashed.
> I tried recompiling hal, dbus, etc. I tried different kernels. I tried
> the git
> version of hal. I enabled debugging in hal which generated masses of
> data,
> mostly unintelligible. I did see some messages about the cd drives near
> the
> end of the debug messages.
> Finally I removed one of the cd drives. Everything now works again.
> I suspect some sort of race condition with dual cd drives (1 sata, 1
> pata) and
> a dual core processor.

I get a flood of errors from my pata dvd-rom in dmesg. This on a quad
core, only the 1 dvd-rom on pata and just 1 hard disk on sata. In the
past the drive used to stop working after some hours of uptime, but this
no longer occurs with kernel

The flood of messages I get are all repeats of this:

hda: status error: status=0x58 { DriveReady SeekComplete DataRequest }
ide: failed opcode was: unknown
hda: drive not ready for command

Anecdotally, this is a similar message to that which I saw every boot
some 10 years ago. The drive in question then was a whopping 200MB and
worked flawlessly regardless of the error.

wow.. wondering how to make it more general and less hard-coded is making my
head hurt. that's a good sign that it's my code

Archive powered by MHonArc 2.6.24.

Top of Page