[SM-Grimoire-Bugs] [Bug 15994] Upgrading udev from stable-0.56-1 to stable-rc-0.57 (and test 2011-06-08) fails

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Thu Jun 9 13:03:01 EDT 2011


http://bugs.sourcemage.org/show_bug.cgi?id=15994


Eric Sandall <sandalle at sourcemage.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ASSIGNED                    |RESOLVED
         Resolution|                            |FIXED
               Flag|                            |fixed_in_lesser_branch+




--- Comment #5 from Eric Sandall <sandalle at sourcemage.org>  2011-06-09 12:02:50 ---
(In reply to comment #4)
> I have a fix for this, but neither of my two test VMs (x86 with glib2 and
> x86_64 without glib2) would come back up after a reboot. Will check the issue
> when I get home.

It was a kernel update to 2.6.39.1 that broke the boot (didn't use my 2.6.38.5
kernel config for some reason) and not the udev changes.

Fixed in test with:
commit 802f34cbffee44933e5c75d6298bc4834bed8b4d
Author: Eric Sandall <sandalle at sourcemage.org>
Date:   Thu Jun 9 10:01:19 2011 -0700

    udev: Fix Bug #15994
    extras split to glib2 (gudev) and --enable-udev_acl
    Remove old '--enable-extras' and switch to '--enable-udev_acl'
    Remove old '--disable-extras' and switch to '--disable-udev_acl'
    Move depends glib2 to optional_depends for hash function
    Change ACL check to '--enable-udev_acl'

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


More information about the SM-Grimoire-Bugs mailing list