[SM-Grimoire-Bugs] [Bug 15994] Upgrading udev from stable-0.56-1 to stable-rc-0.57 (and test 2011-06-08) fails

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Wed Jun 8 21:10:13 EDT 2011


http://bugs.sourcemage.org/show_bug.cgi?id=15994





--- Comment #1 from Eric Sandall <sandalle at sourcemage.org>  2011-06-08 20:10:11 ---
# cast -c udev
Computing previously installed dependencies...
udev preparing environment...
udev running configuration...
[[ Compile extra debugging messages? -> n ]]
[[ Compile hash function generator and access control lists -> n ]]
Init script coldplug is "ESSENTIAL" for system startup,
it is recommended that you answer yes to the following
queries unless you know exactly what you're doing.
Install init script coldplug? [y] y
Enable init script coldplug? [y] y
Init script udevd is "ESSENTIAL" for system startup,
it is recommended that you answer yes to the following
queries unless you know exactly what you're doing.
Install init script udevd? [y] y
Enable init script udevd? [y] y
Install init script copy-persistent-rules? [n] n
udev checking dependencies...
udev has a dependency on gnupg
udev has a dependency on smgl-fhs
udev has a dependency on gperf
udev has a dependency on usbutils
udev has a dependency on some PCIIDS.
        (0)     hwdata
        (1)     pciutils         (installed)

Which one do you want? [1] 1
udev has a dependency on pciutils
udev requests pciutils with NO_ZLIB
udev has an optional dependency on acl (for local user acl permissions support)
Do you want to cast acl? [n] n
udev has a disabled optional dependency on gobject-introspection
udev has a disabled optional dependency on gtk-doc
udev has a disabled optional dependency on libselinux
udev has an optional dependency on some SYSTEM-LOGGER (for logging to syslog).
Continue to use metalog? [y] y
udev checking for reverse triggers...
gnupg No work to do.
smgl-fhs No work to do.
gperf No work to do.
usbutils No work to do.
pciutils No work to do.
metalog No work to do.
Collating dependencies...
Spells are to be cast:
---------------------------
udev

Do you want to cast these spells? [y] y
...
checking for GLIB... no
configure: error: Package requirements (glib-2.0 >= 2.22.0 gobject-2.0 >=
2.22.0) were not met:

No package 'glib-2.0' found
No package 'gobject-2.0' found

$ cat /etc/sorcery/local/depends/udev.p
UDEV_OPTS="--disable-debug --disable-extras"
INIT_INSTALLED="coldplug udevd"
INIT_NOT_INSTALLED="copy-persistent-rules"
INIT_ENABLED="coldplug udevd"
INIT_DISABLED=""

Seems like glib2 is always required now, regardless of extras?

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the SM-Grimoire-Bugs mailing list