[SM-Grimoire-Bugs] [Bug 15994] New: Upgrading udev from stable-0.56-1 to stable-rc-0.57 (and test 2011-06-08) fails

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Wed Jun 8 21:05:02 EDT 2011


http://bugs.sourcemage.org/show_bug.cgi?id=15994

           Summary: Upgrading udev from stable-0.56-1 to stable-rc-0.57
                    (and test 2011-06-08) fails
           Product: Codex
           Version: stable-rc grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: disk
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org



Eric Sandall <sandalle at sourcemage.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
               Flag|                            |must_fix_before_release+


$ sorcery -v
1.14.5

$ cat /var/lib/sorcery/codex/stable/VERSION
0.56-1
e7f34338271920f615bb56158f7d73b683d5ee7f

# scribe rem stable; scribe add stable-rc

$ cat /var/lib/sorcery/codex/stable-rc/VERSION
0.57-rc
720671b4a535a3580b81bcbe293a24a309515817

Tested with test on 2011-06-08, verified on stable-rc-0.57.

# sorcery -s
...
Spells installed successfully:
------------------------------
bison                   fuse                    autoconf                libusb 
                pciutils                grep                    p7zip          
        util-linux
file                    perl                    glibc                  
libusb-compat           locale                  libgssglue             
automake
linux                   vim                     gperf                  
usbutils                readline                module-init-tools       parted


Spells that had a check_self trigger succeed:
---------------------------------------------
vim


Spells that have been dropped:
------------------------------
e2fsprogs       init.d


Spells that encountered problems:
---------------------------------
udev

The install queue is not empty,
it still contains the following spells:
---------------------------------------
init.d  udev

Cast deferred installing some configuration files.
The following spells have new pending updates:
----------------------------------------------
module-init-tools
Please run confmeld to merge them into your system.

$ gaze version udev init.d glib2 gobject-introspection
Grimoire  Section      Spell                  Grimoire Version  Installed
Version
--------  -------      -----                  ---------------- 
-----------------
test      disk         udev                   171               167
test      smgl         init.d                 2.2.11            2.2.7
test      gnome2-libs  glib2                  2.28.8            -
test      gnome2-libs  gobject-introspection  0.10.8            -

$ bzless /var/log/sorcery/compile/udev-171.bz2
...
checking for GLIB... no
configure: error: Package requirements (glib-2.0 >= 2.22.0 gobject-2.0 >=
2.22.0) were not met:

No package 'glib-2.0' found
No package 'gobject-2.0' found

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the SM-Grimoire-Bugs mailing list