[SM-Grimoire-Bugs] [Bug 15999] strigi 0.7.5 cannot find qt4

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Sat Jul 23 04:58:51 EDT 2011


http://bugs.sourcemage.org/show_bug.cgi?id=15999


Bor Kraljič <pyrobor at ver.si> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |pyrobor at ver.si




--- Comment #1 from Bor Kraljič <pyrobor at ver.si>  2011-07-23 03:58:46 ---
It compiles just fine for me. So lets try to find the difference in our qt4
install:

First thing do you have DBUS support in qt4 ?

---{ qt4: depends }---
qt4:g++:on:required::
qt4:zlib:on:required::
qt4:libx11:on:required::
qt4:libxcursor:on:required::
qt4:libxfixes:on:required::
qt4:libxi:on:required::
qt4:libxrender:on:required:: 
qt4:libxrandr:on:required::
qt4:libxext:on:required:: 
qt4:fontconfig:on:optional:-fontconfig:-no-fontconfig
qt4:jpeg(JPEG):on:optional:-system-libjpeg:-qt-libjpeg
qt4:nvidia_driver(OPENGL):on:optional:-opengl:-no-opengl
qt4:libpng:on:optional:-system-libpng:-qt-libpng
qt4:(FIREBIRD):off:optional:-plugin-sql-ibase  -I/opt/firebird/include         
           -L/opt/firebird/lib:-no-sql-ibase
qt4:mariadb(MYSQL):on:optional:-plugin-sql-mysql  -I/usr/include/mysql         
           -L/usr/lib  -lmysqlclient:-no-sql-mysql
qt4:sqlite:on:optional:-plugin-sql-sqlite  -I/usr/include                    
-L/usr/lib  -lsqlite3:-no-sql-sqlite
qt4:postgresql:off:optional:-plugin-sql-psql  -I/src/include/postgresql        
                          -I/usr/include/server/libpq  -L/usr/lib 
-lpq:-no-sql-psql
qt4:libiodbc(ODBC-MGR):on:optional:-plugin-sql-odbc -I/usr/include:-no-sql-odbc
qt4:cups(CUPS):on:optional:-cups:-no-cups
qt4:glib2:on:optional:-glib:-no-glib
qt4:nas:off:optional:-system-nas-sound:-no-nas-sound
qt4:gtk+2:on:optional:-gtkstyle:-no-gtkstyle
qt4:dbus:on:required::
qt4:openssl:on:required::
---{ qt4: persistent_config }---
QT_TMPFS="n"
QT_DOC="n"
QT_DEMO="-nomake"
QT_EXAMPLE="-nomake"
QT_TOOLS="-make"
QT_TRANS="-make"
QT_STL="-stl"
QT_QT3="-qt3support"
QT_DEBUG="-no-separate-debug-info"
QT_NIS="-nis"
QT_XRAMA="-xinerama"
QT_GIF="-qt-gif"
QT_EXCEPT="-exceptions"
QT_PCH="-pch"
QT_WEBKIT="-webkit"
QT_MEDIA="-multimedia"
QT_GTK="-gtkstyle"
QT_PHONON="-no-phonon -no-phonon-backend"
QT_ACCESS="-accessibility"
---{ qt4: rsub_depends }---
---{ qt4: sub_depends }---
quassel:qt4:DBUS
quassel:qt4:SSL

Also wich discovered:
[10:47:22] <wich> okay, found it /usr/bin/qt4 needs to be in PATH
[10:47:54] <wich> or maybe you can tell strigi cmake where to look
[10:50:12] <wich> however there's still an upstream bug there as well, they
test for Qt4 optionally, however they use a qt4 specific call in their dbus
cmake files, so if dbus is enabled then qt4 is not optional
[10:50:23] <wich> but I don't feel like filing


So you might just have to answer "y" to [[ do you want to use a GUI (qt4)? -> n
]] and it will compile...


PS: Use chill for your next bug :)

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the SM-Grimoire-Bugs mailing list