[SM-Grimoire-Bugs] [Bug 15999] New: strigi 0.7.5 cannot find qt4

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Mon Jul 18 17:51:47 EDT 2011


http://bugs.sourcemage.org/show_bug.cgi?id=15999

           Summary: strigi 0.7.5 cannot find qt4
           Product: Codex
           Version: test grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: utils
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org


$ sorcery -v
1.14.5

$ gaze version cmake dbus qt4 strigi
Grimoire  Section       Spell   Grimoire Version  Installed Version
--------  -------       -----   ----------------  -----------------
test      devel         cmake   2.8.5             2.8.5
test      utils         dbus    1.4.12            1.4.12
test      x11-toolkits  qt4     4.7.3             4.7.3
test      utils         strigi  0.7.5             0.7.2

# cast strigi
Computing previously installed dependencies...
strigi preparing environment...
[[ Do you want the SVN version? -> n ]]
strigi running configuration...
[[ do you want to use a GUI (qt4)? -> n ]]
strigi checking dependencies...
strigi has a dependency on g++
strigi has a dependency on cmake
strigi has a dependency on bzip2
strigi has a dependency on pkgconfig
strigi has a dependency on openssl
strigi has a dependency on clucene
strigi has a dependency on libxml2
strigi has an enabled optional dependency on dbus
strigi has an optional dependency on some FAM (file change monitoring).
Continue to use gamin? [y] 
strigi has an enabled optional dependency on sqlite
strigi has an enabled optional dependency on exiv
...
-- Found Perl: /usr/bin/perl
-- Could NOT find Qt4 (missing:  QT_QMAKE_EXECUTABLE QT_MOC_EXECUTABLE
QT_RCC_EXECUTABLE QT_UIC_EXECUTABLE QT_INCLUDE_DIR QT_LIBRARY_DIR
QT_QTCORE_LIBRARY) (Required is at least version "4.3.0")
** Qt4 not found. Support for Qt4 GUI client is disabled
Qt QTGUI library not found.
Qt QTCORE library not found.
CMake Error at strigiclient/lib/searchclient/qtdbus/CMakeLists.txt:15
(qt4_wrap_cpp):
  Unknown CMake command "qt4_wrap_cpp".


-- Configuring incomplete, errors occurred!
 ! Problem Detected ! 
Creating compile log /var/log/sorcery/compile/strigi-0.7.5.bz

I tested the following packages which also require qt4, and they found it just
fine:
soprano
akonadi
phonon
pyqt4

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the SM-Grimoire-Bugs mailing list