[SM-Grimoire-Bugs] [Bug 15939] New: openoffice 2.1. fails to find Qt4

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Mon Feb 7 19:07:00 EST 2011


http://bugs.sourcemage.org/show_bug.cgi?id=15939

           Summary: openoffice 2.1. fails to find Qt4
           Product: Codex
           Version: stable grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: editors
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org


$ sorcery -v
1.14.6-rc1

$ gaze version qt4 openoffice
Grimoire  Section       Spell       Grimoire Version  Installed Version
--------  -------       -----       ----------------  -----------------
test      x11-toolkits  qt4         4.7.1             4.7.1
test      editors       openoffice  3.2.1             -

# cast openoffice
...
openoffice has an optional dependency on kdebase4 (enable KDE addressbook and
vclplugin)
Do you want to use kdebase4? [y]
...
checking whether to build the Report Builder extension... no
checking for Qt4 headers... /usr/include 
checking for Qt4 libraries... /usr/lib   
checking for moc... no
configure: error: Qt Meta Object Compiler not found.  Please specify
the root of your Qt installation by exporting QT4DIR before running
"configure".
/var/lib/sorcery/codex/test/editors/openoffice/BUILD: line 27:
Linux*Env.Set.sh: No such file or directory

If I say 'n' to using kdebase4, the compile proceeds from there.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list