[SM-Grimoire-Bugs] [Bug 15673] kdebindings4 dies with the current version of attica in test

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri May 21 17:33:27 EDT 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15673





--- Comment #6 from Eric Sandall <sandalle at sourcemage.org>  2010-05-21 16:33:26 ---
Hrm...did you guys try rebuilding all of KDE4 after this? kdebase4-runtime now
seems to fail:
Linking CXX executable ksvgtopng
[ 93%] Built target ksvgtopng
[ 93%] Built target oxygen_automoc
[ 98%] Built target oxygen
[ 98%] Built target kstyle_oxygen_config_automoc
[100%] Built target kstyle_oxygen_config
[100%] Built target attica_kde_automoc
[100%] Building CXX object
attica/kdeplugin/CMakeFiles/attica_kde.dir/kdeplatformdependent.o
/usr/src/kdebase-runtime-4.4.3/attica/kdeplugin/kdeplatformdependent.cpp:193:
warning: unused parameter 'baseUrl'
/usr/src/kdebase-runtime-4.4.3/attica/kdeplugin/kdeplatformdependent.cpp:193:
warning: unused parameter 'user'
/usr/src/kdebase-runtime-4.4.3/attica/kdeplugin/kdeplatformdependent.cpp:193:
warning: unused parameter 'password'
/usr/src/kdebase-runtime-4.4.3/attica/kdeplugin/kdeplatformdependent.cpp: In
function 'QObject* qt_plugin_instance()':
/usr/src/kdebase-runtime-4.4.3/attica/kdeplugin/kdeplatformdependent.cpp:225:
error: cannot allocate an object of abstract type
'Attica::KdePlatformDependent'
/usr/src/kdebase-runtime-4.4.3/attica/kdeplugin/kdeplatformdependent.h:42:
note:   because the following virtual functions are pure within
'Attica::KdePlatformDependent':
/usr/include/attica/platformdependent.h:47: note:       virtual void
Attica::PlatformDependent::addDefaultProviderFile(const QUrl&)
/usr/include/attica/platformdependent.h:48: note:       virtual void
Attica::PlatformDependent::removeDefaultProviderFile(const QUrl&)
/usr/include/attica/platformdependent.h:53: note:       virtual void
Attica::PlatformDependent::enableProvider(const QUrl&, bool) const
/usr/include/attica/platformdependent.h:54: note:       virtual bool
Attica::PlatformDependent::isEnabled(const QUrl&) const
make[2]: ***
[attica/kdeplugin/CMakeFiles/attica_kde.dir/kdeplatformdependent.o] Error 1
make[1]: *** [attica/kdeplugin/CMakeFiles/attica_kde.dir/all] Error 2
make: *** [all] Error 2

$ gaze version attica kdebindings4 kdebase4-runtime
Grimoire  Section       Spell             Grimoire Version  Installed Version
--------  -------       -----             ----------------  -----------------
test      kde4-support  attica            0.1.4             0.1.4
test      kde4          kdebindings4      4.4.3             4.4.3
test      kde4          kdebase4-runtime  4.4.3             4.4.3

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list