[SM-Grimoire-Bugs] [Bug 15711] New: planner 0.14.3 fails to compile with libgnome 2.30

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Mon May 17 17:16:51 EDT 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15711

           Summary: planner 0.14.3 fails to compile with libgnome 2.30
           Product: Codex
           Version: stable grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: gnome2-apps
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org


$ gaze version planner libgnome
Grimoire  Section      Spell     Grimoire Version  Installed Version
--------  -------      -----     ----------------  -----------------
test      gnome2-apps  planner   0.14.3            -
test      gnome2-libs  libgnome  2.30.0            2.30.0

$ sorcery -v
1.14.4

Applies to at least last two stables:
$ cat /var/lib/sorcery/codex/stable/VERSION 
0.43-3
696ac4791093cdedccfab2576c2b2a3f20bf4f5d

$ cat /var/lib/sorcery/codex/stable/VERSION 
0.44-0
26e2cb57cb45aaa05c8dceecc70a1a79f2b85b42

# cast planner
Computing previously installed dependencies...
planner preparing environment...
planner checking dependencies...
planner has a dependency on libgnomeui
planner has a dependency on libgnomeprintui
planner has a dependency on libglade2
planner has a dependency on gconf2
planner has a dependency on libgsf
planner has a dependency on libgda2
planner has an optional dependency on postgresql (For database support)
Do you want to cast postgresql? [n] 
planner has an optional dependency on evolution-data-server (For
evolution-data-server support)
Do you want to use evolution-data-server? [y]
...
Making all in utils
make[3]: Entering directory `/usr/src/planner-0.14.3/eds-backend/utils'
if gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../.. -DORBIT2=1 -pthread
-I/us
r/include/evolution-data-server-2.30 -I/usr/include/ -I/usr/include/dbus-1.0
-I/
usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/i
nclude/gconf/2 -I/usr/include/libsoup-2.4 -I/usr/include/orbit-2.0
-I/usr/lib/db
us-1.0/include -I/usr/include/evolution-2.30 -I/usr/include/unique-1.0
-I/usr/in
clude/libgtkhtml-3.14 -I/usr/include/libgtkhtml-3.14/editor
-I/usr/include/libgn
omecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include
-I/usr/include/a
tk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1
-I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/enchant
-I/usr/include/gail-1.0 -I/usr/include/libart-2.0      -march=native
-mtune=native -m64 -pipe -DPIC -fPIC -O2 -msse -msse2 -mssse3 -mmmx
-mfpmath=sse -MT create-planner-source.o -MD -MP -MF
".deps/create-planner-source.Tpo" -c -o create-planner-source.o
create-planner-source.c; \
        then mv -f ".deps/create-planner-source.Tpo"
".deps/create-planner-source.Po"; else rm -f ".deps/create-planner-source.Tpo";
exit 1; fi
create-planner-source.c:25:33: error: libgnome/gnome-init.h: No such file or
directory
create-planner-source.c: In function 'main':
create-planner-source.c:74: error: 'LIBGNOME_MODULE' undeclared (first use in
this function)
create-planner-source.c:74: error: (Each undeclared identifier is reported only
once
create-planner-source.c:74: error: for each function it appears in.)
make[3]: *** [create-planner-source.o] Error 1
make[3]: Leaving directory `/usr/src/planner-0.14.3/eds-backend/utils'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/planner-0.14.3/eds-backend'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/planner-0.14.3'
make: *** [all] Error 2

Tried updating to 0.14.4 with the same issue.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list