[SM-Grimoire-Bugs] [Bug 15705] New: gametable fails to download with aria2 as download tool

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Mon May 3 16:30:31 EDT 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15705

           Summary: gametable fails to download with aria2 as download
                    tool
           Product: Codex
           Version: binary grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: games grimoire
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: pyrobor at ver.si


Note that this only happens if you don't have enabled optional depends on
ca-certificates in aria2 spell. (commit
ad31832879ece47a02c3ab2accd1a344454d5bfa)

Now here are the options:

1) we add SOURCE_HINTS=no-check-certificate to spell gametable

2) we create subdependency for ca-certificates in aria2 and then put "subdepend
aria2 CERT"

3) we compile aria2 with --with-ca-bundle='/etc/ssl/certs/ca-certificates.crt'.
It compiles without error. And then add normal "depends ca-certificates" to
gamestable. The downside of this option is that we get error with every
download: 2010-05-03 20:34:33.290446 ERROR - Failed to load trusted CA
certificates from /etc/ssl/certs/ca-certificates.crt. Cause:
error:02001002:system library:fopen:No such file or directory
If we install ca-certificates the error goes away. Even if ca-certificates is
installed after the aria2.

I think that the best solution is the simplest solution. So I vote for solution
1. Comments on which solution is the best are welcome. And I am also open to
new options.


PS: There is no binary grimoire in component... So I chose games grimoire...
Closes thing I could find...

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list