[SM-Grimoire-Bugs] [Bug 15730] GPA fails to build due to API-mismatch with LibAssuan (want 1, got 2)

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Wed Jun 2 15:28:12 EDT 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15730





--- Comment #5 from Moesasji <henkjans_bagger at hotmail.com>  2010-06-02 14:28:10 ---
My versions...


--------------------------------------------------------------------
bash-4.1# gaze version gpgme libgpg-error gtk+2 libassuan gpa
Grimoire    Section       Spell         Grimoire Version  Installed Version
--------    -------       -----         ----------------  -----------------
stable      crypto        gpgme         1.3.0             1.3.0
stable      crypto        libgpg-error  1.7               1.7
stable      x11-toolkits  gtk+2         2.20.0            2.20.0
stable      crypto        libassuan     2.0.0             2.0.0
mygrimoire  crypto        gpa           svn               svn

bash-4.1# gpa --version 
gpa 0.9.1-svn1025
Copyright (C) 2000-2002 Miguel Coca, G-N-U GmbH, Intevation GmbH.
Copyright (C) 2008, 2009 g10 Code GmbH.
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions.  See the file COPYING for details.
------------------------------------------------------------------------


Only obvious difference is the version of libgpg-error...however using
libgpg-error 1.8 from testing makes no difference. (I did rebuild all of these
spells)

Strangely enough I do now see additional info in the console (but might not
have spotted it previously):

** (gpa:27889): CRITICAL **: gpa_start_simple_gpg_command: assertion `argv[0]'
failed

Two hits on this one: one on the GPA-site itself and one in Debian Bugzilla
pointing to a problem with gpgme, see https://bugs.g10code.com/gnupg/issue1134 
Too vague to be useful (to me)
-----

Just for comparison: my compiler-flags:

SMGL_COMPAT_ARCHS=64/x86_64/native-x86_64-64/
ARCHITECTURE="native-x86_64-64"
OPTIMIZATIONS="combreloc prelink strip "
CUSTOM_CFLAGS="-O2"
CUSTOM_CXXFLAGS="-O2"
CUSTOM_LDFLAGS="-Wl,-O1,--as-needed,--hash-style=gnu,--sort-common"
CFLAGS="-march=native -mtune=native -m64 -pipe -DPIC -fPIC -O2"
CXXFLAGS="-march=native -mtune=native -m64 -pipe -DPIC -fPIC -O2"
LDFLAGS="-z combreloc -s -Wl,-O1,--as-needed,--hash-style=gnu,--sort-common"
HOST="x86_64-pc-linux-gnu"

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list