[SM-Grimoire-Bugs] [Bug 15730] New: GPA fails to build due to API-mismatch with LibAssuan (want 1, got 2)

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Tue Jun 1 18:37:39 EDT 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15730

           Summary: GPA fails to build due to API-mismatch with LibAssuan
                    (want 1, got 2)
           Product: Codex
           Version: stable grimoire
          Platform: x86-64
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: crypto
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: henkjans_bagger at hotmail.com


Created an attachment (id=7471)
 --> (http://bugs.sourcemage.org/attachment.cgi?id=7471)
patch from Slamd64 that might be part of the solution...

Compiling GPA 0.9.0 from stable or test fails during the configure stage due to
incorrect libassuan-api. Relevant section from the compile log

---
checking where the gettext function comes from... libc
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.10.0... yes (version 2.20.0)
checking for gpg-error-config... /usr/bin/gpg-error-config
checking for GPG Error - version >= 1.4... yes (1.7)
checking for libassuan-config... /usr/bin/libassuan-config
checking for LIBASSUAN - version >= 1.0.4... yes (2.0.0)
checking LIBASSUAN API version... does not match.  want=1 got=2.
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
checking for gpgme-config... /usr/bin/gpgme-config
checking for GPGME - version >= 1.2.0... yes

<snip> 

configure:
***
*** You need libassuan to build this program.
*** This library is for example available at
***   ftp://ftp.gnupg.org/gcrypt/libassuan/
*** (at least version 1.0.4 is required).
***
configure: error:
---

This same problem was discussed here:
http://www.linuxquestions.org/questions/slackware-14/having-trouble-building-gnupgs-gpa-795648/
which points to a patch from slamd64
(http://connie.slackware.com/~rworkman/gpa/)pulled from GPA svn:
https://svn.wald.intevation.org/svn/gpa/trunk/ (changelog indeed indicates a
fix to the libassuan api)

Unfortunately although this patch applies cleanly it doesn't (seem to) solve
the configure problem...

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list