[SM-Grimoire-Bugs] [Bug 15779] New: acpica-unix and iasl

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Tue Jul 27 10:05:03 EDT 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15779

           Summary: acpica-unix and iasl
           Product: Codex
           Version: test grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: devel
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: hgr at vabo.cz


We have acpica-unix in z-rejected grimoire even it is dual licensed.

>From http://acpica.org/documentation/faq.php :

Under what licensing is the ACPICA source released?
ACPICA can be licensed under the GNU General Public License or via a separate
license that may be more favorable to commercial OSVs. Please see the source
code license header for specifics. 

Imho, no problem to set LICENSE just to GPL and move it into standard grimoire.

Next problem is that we have iasl spell uses the same sources.

Imho, we can remove iasl spell because acpi-unix provides iasl:
config_query  IASL  "Install iasl, an ASL compiler/decompiler?"  y  &&

acpi-unix will need SUB_DEPENDS iasl and virtualbox will need to update DEPENDS
to depends -sub IASL acpi-unix.



# gaze version acpica-unix iasl
Grimoire    Section  Spell        Grimoire Version  Installed Version
--------    -------  -----        ----------------  -----------------
z-rejected  z-devel  acpica-unix  20100331          -
test        devel    iasl         20091112          20091112

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list