[SM-Grimoire-Bugs] [Bug 15760] New: util-linux 2.18 has undefined reference to get_wch during compilation

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Thu Jul 8 02:45:39 EDT 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15760

           Summary: util-linux 2.18 has undefined reference to get_wch
                    during compilation
           Product: Codex
           Version: stable-rc grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: utils
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org


$ gaze version kbd e2fsprogs gnupg smgl-fhs zlib nfs-utils gcc g++ glibc
Grimoire   Section       Spell       Grimoire Version  Installed Version
--------   -------       -----       ----------------  -----------------
stable-rc  utils         kbd         1.15.2            1.15.2
stable-rc  disk          e2fsprogs   1.41.12           1.41.12
stable-rc  crypto        gnupg       1.4.10            1.4.10
stable-rc  smgl          smgl-fhs    2.2.2             2.2.2
stable-rc  archive-libs  zlib        1.2.5             1.2.5
stable-rc  net           nfs-utils   1.1.6             1.1.6
stable-rc  gnu           gcc         4.4.3             4.4.3
stable-rc  gnu           g++         4.4.3             4.4.3
stable-rc  libs          glibc       2.11.2            2.11.2
stable-rc  utils         util-linux  2.18              2.17.2

$ sorcery -v
1.14.4

$ cat /var/lib/sorcery/codex/stable-rc/VERSION 
0.46-rc
ed4487dbacdadbbd877f1fa3f521b3ba4cf07351

# cast util-linux
Computing previously installed dependencies...
util-linux preparing environment...
aes version is older usually, but needed for loop-AES patch
[[ What version do you want to use? -> 'latest' ]]
util-linux running configuration...
[[ Do you want to enable selinux support? -> n ]]
Init script hwclock.sh is "RECOMMENDED" for system startup, 
it is recommended that you answer yes to the following queries.
Install init script hwclock.sh? [y] 

Enable init script hwclock.sh? [y] 

util-linux checking dependencies...
util-linux has a dependency on some CONSOLE-TOOLS.
Continue to use kbd? [y] 

util-linux has a dependency on e2fsprogs
util-linux has a dependency on gnupg
util-linux has a dependency on smgl-fhs
util-linux has a dependency on zlib
util-linux has an enabled optional dependency on nfs-utils
...
/usr/bin/make  all-recursive
make[1]: Entering directory `/usr/src/util-linux-ng-2.18'
Making all in include
make[2]: Entering directory `/usr/src/util-linux-ng-2.18/include'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/src/util-linux-ng-2.18/include'
Making all in disk-utils
make[2]: Entering directory `/usr/src/util-linux-ng-2.18/disk-utils'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/src/util-linux-ng-2.18/disk-utils'
Making all in fdisk
make[2]: Entering directory `/usr/src/util-linux-ng-2.18/fdisk'
  CCLD   cfdisk
cfdisk-cfdisk.o: In function `get_string':
cfdisk.c:(.text+0x2513): undefined reference to `get_wch'
collect2: ld returned 1 exit status
make[2]: *** [cfdisk] Error 1
make[2]: Leaving directory `/usr/src/util-linux-ng-2.18/fdisk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/util-linux-ng-2.18'
make: *** [all] Error 2

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list