[SM-Grimoire-Bugs] [Bug 15551] New: arora fails to compile

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Jan 22 05:21:43 EST 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15551

           Summary: arora fails to compile
           Product: Codex
           Version: test grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: http
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: pyrobor at ver.si


Fails to compile. Probably problem with qt4. I have it installed 4.6.1. But it
didn't compile for me even with 4.6.0. I tried version 0.10.2 and the git
version available in grimoire. Both give me the same error:

make[2]: Entering directory `/usr/src/arora-git/tools/htmlToXBel'
g++ -c -pipe -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_GUI_LIB
-DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED
-I../../../../share/qt4/mkspecs/linux-g++ -I. -I../../../../include/QtCore
-I../../../../include/QtNetwork -I../../../../include/QtGui
-I../../../../include/QtWebKit -I../../../../include -I. -I.moc -o .obj/main.o
main.cpp
In file included from main.cpp:21:
/usr/include/QtWebKit/QtWebKit:4:39: error: QtXmlPatterns/QtXmlPatterns: No
such file or directory
make[2]: *** [.obj/main.o] Error 1
make[2]: Leaving directory `/usr/src/arora-git/tools/htmlToXBel'
make[1]: Leaving directory `/usr/src/arora-git/tools'
make[1]: *** [sub-htmlToXBel-make_default-ordered] Error 2
make: *** [sub-tools-make_default-ordered] Error 2

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list