[SM-Grimoire-Bugs] [Bug 15586] New: kdegraphics4 4.4.0 fails to find nepomuk

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Feb 19 20:19:35 EST 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15586

           Summary: kdegraphics4 4.4.0 fails to find nepomuk
           Product: Codex
           Version: test grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: kde4
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org


$ gaze version qt4 shared-desktop-ontologies soprano freetype2 kdebase4-runtime
kdebase-workspace4 kdegraphics4
Grimoire  Section        Spell                      Grimoire Version  Installed
Version
--------  -------        -----                      ---------------- 
-----------------
test      x11-toolkits   qt4                        4.6.2             4.6.2
test      kde4-support   shared-desktop-ontologies  0.2               0.2
test      kde4-support   soprano                    2.4.0.1           2.4.0.1
test      graphics-libs  freetype2                  2.3.12            2.3.12
test      kde4           kdebase4-runtime           4.4.0             4.4.0
test      kde4           kdebase-workspace4         4.4.0             4.4.0
test      kde4           kdegraphics4               4.4.0             4.3.5

$ gaze from nepomuk
kdebase4-runtime-4.4.0:/opt/kde4/share/doc/HTML/en/kcontrol/nepomuk
kdebindings4-4.4.0:/usr/share/sip/PyKDE4/nepomuk
shared-desktop-ontologies-0.2:/usr/share/ontology/nepomuk

$ gaze from Nepomuk
kdelibs4-4.4.0:/opt/kde4/include/KDE/Nepomuk

# cast kdegraphics4
Computing previously installed dependencies...
kdegraphics4 preparing environment...
kdegraphics4 running configuration...
[[ Enable debug code? -> n ]]
kdegraphics4 checking dependencies...
kdegraphics4 has a dependency on g++
kdegraphics4 has a dependency on cmake
kdegraphics4 has a dependency on kdebase4-runtime
kdegraphics4 has an enabled optional dependency on kdebase-workspace4
kdegraphics4 has a dependency on shared-desktop-ontologies
kdegraphics4 has a dependency on soprano
kdegraphics4 has a dependency on freetype2
kdegraphics4 has a dependency on lcms
kdegraphics4 has an enabled optional dependency on ghostscript
kdegraphics4 requests ghostscript with LIBS
kdegraphics4 has a disabled optional dependency on libgphoto2
kdegraphics4 has an enabled optional dependency on exiv2
kdegraphics4 has a disabled optional dependency on sane-backends
kdegraphics4 has an enabled optional dependency on libspectre
kdegraphics4 has an enabled optional dependency on tiff
kdegraphics4 has an enabled optional dependency on jpeg
kdegraphics4 has an enabled optional dependency on poppler
kdegraphics4 requests poppler with QT4
kdegraphics4 has a disabled optional dependency on chmlib
kdegraphics4 has a disabled optional dependency on djvulibre
kdegraphics4 has an enabled optional dependency on qca2
kdegraphics4 has an enabled optional dependency on qimageblitz
kdegraphics4 has an enabled optional dependency on libxxf86vm
kdegraphics4 has an enabled optional dependency on xf86vidmodeproto
...
-- Looking for include files HAVE_STRSTREAM_H - not found.
-- Found Soprano: /usr/include
-- Found SharedDesktopOntologies: /usr/share/ontology
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:70
(MESSAGE):
  Could NOT find Nepomuk (missing: NEPOMUK_LIBRARIES NEPOMUK_INCLUDE_DIR
  SOPRANO_PLUGIN_REDLANDBACKEND_FOUND)
Call Stack (most recent call first):
  /opt/kde4/share/apps/cmake/modules/FindNepomuk.cmake:69
(find_package_handle_standard_args)
  gwenview/CMakeLists.txt:23 (find_package)


-- Configuring incomplete, errors occurred!

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list