[SM-Grimoire-Bugs] [Bug 15578] New: xterm 253 cannot find PCRE POSIX

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Thu Feb 18 00:47:06 EST 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15578

           Summary: xterm 253 cannot find PCRE POSIX
           Product: Codex
           Version: stable grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: xfce
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org


Also fails with xterm 255.

$ gaze version pcre perl 
Grimoire  Section      Spell  Grimoire Version  Installed Version
--------  -------      -----  ----------------  -----------------
test      libs         pcre   8.01              8.01
test      devel        perl   5.10.1            5.10.1
test      xorg-extras  xterm  255               253

# cast xterm
Computing previously installed dependencies...
xterm preparing environment...
xterm running configuration...
[[ Enable X11R6.3 active-icon feature? -> y ]]
[[ Enable ANSI color support? -> y ]]
[[ Enable 16-color support? -> y ]]
[[ Enable 256-color support? -> n ]]
[[ Enable 88-color support? -> n ]]
[[ Enable support for blinking cursor? -> y ]]
[[ Allow -k8 option for printable 128-159? -> y ]]
[[ Enable PC-style mapping of bold colors? -> y ]]
[[ Enable separate color class resources? -> y ]]
[[ Enable default colorMode resource? -> y ]]
xterm checking dependencies...
xterm has a dependency on fontconfig
xterm has a dependency on freetype2
xterm has a dependency on libice
xterm has a dependency on libsm
xterm has a dependency on libx11
xterm has a dependency on libxaw
xterm has a dependency on libxext
xterm has a dependency on libxft
xterm has a dependency on libxmu
xterm has a dependency on libxrender
xterm has a dependency on libxt
xterm has a dependency on ncurses
xterm has an enabled optional dependency on xaw3d
xterm has an enabled optional dependency on freetype2
xterm has an enabled optional dependency on luit
xterm has an optional dependency on pcre (for Perl 5 regular expressions)
Do you want to use pcre? [y]
...
checking if you want support for regular-expression selections... yes
checking if you want to use PCRE for regular-expressions... yes
checking for pcre_compile in -lpcre... yes
checking for pcreposix.h... yes
checking for pcreposix_regcomp in -lpcreposix... no
configure: error: Cannot find PCRE POSIX library
 ! Problem Detected !

Compiles fine if you say 'n' to depending on pcre for Perl 5 regular
expressions.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list