[SM-Grimoire-Bugs] [Bug 15552] policykit 0.96 fails to compile

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Wed Feb 10 13:03:30 EST 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15552





--- Comment #4 from Arwed v. Merkatz <v.merkatz at gmx.net>  2010-02-10 12:03:27 ---
That's the cleaner solution. If I remember correctly, I didn't want to use
linux-pam, but something required policykit. This does not seem the case
anymore. The only non-library spells I found that depend directly or indirectly
on policykit are now:
gnome-disk-utility
gnome-power-manager
gnome-session

I didn't want to force all gnome users to use pam instead of shadow for their
system. gnome-session is the canonical way to start gnome, but it's possible to
have a fully working desktop without it. So I see 2 options:
- make policykit depend on linux-pam, remove the choice of auth system
- add an option to the spell (default to no) to remove all pam related stuff,
with a warning that might make policykit non-functional

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list