[SM-Grimoire-Bugs] [Bug 15684] New: gtkpod fails to compile with mp4v2

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Wed Apr 21 03:23:59 EDT 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15684

           Summary: gtkpod fails to compile with mp4v2
           Product: Codex
           Version: test grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: audio-players
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org
            Blocks: 15536


$ gaze version gtkpod libgpod mp4v2 libmp4v2
Grimoire  Section         Spell     Grimoire Version  Installed Version
--------  -------         -----     ----------------  -----------------
test      audio-creation  gtkpod    0.99.14           -
test      audio-libs      libgpod   0.7.0             0.7.0
test      audio-libs      mp4v2     1.9.1             1.9.1
test      audio-libs      libmp4v2  1.5.0.1           -

# cast -c gtkpod
Computing previously installed dependencies...
gtkpod preparing environment...
gtkpod checking dependencies...
gtkpod has a dependency on gettext
gtkpod has a dependency on glib2
gtkpod has a dependency on gtk+2
gtkpod has a dependency on libglade2
gtkpod has a dependency on libgpod
gtkpod has a dependency on libid3tag
gtkpod has a dependency on pango
gtkpod has a dependency on libxml2
gtkpod has a dependency on cairo
gtkpod has an optional dependency on curl (Coverart download support)
Do you want to use curl? [y] 
gtkpod has an optional dependency on gnome-vfs2 (VFS device autodetection
support)
Do you want to use gnome-vfs2? [y] 
gtkpod has an optional dependency on hal (HAL device autodetection support)
Do you want to use hal? [y] 
gtkpod has an optional dependency on some MP4V2 (MP4/AAC support).
        (0)     [none]
        (1)     mp4v2    (installed)

Which one do you want? [1] 
gtkpod has an optional dependency on libvorbis (Ogg/Vorbis support)
Do you want to use libvorbis? [y] 
gtkpod has an optional dependency on flac (FLAC support)
Do you want to use flac? [y] 
gtkpod has an optional dependency on xmms (to playback music tracks)
Do you want to cast xmms? [n] 
gtkpod has an optional dependency on sudo (to automatically mount or unmount
your iPod, see the README)
Do you want to use sudo? [y]
...
Making all in src
make[2]: Entering directory `/usr/src/gtkpod-0.99.14/src'
gcc  -march=native -mtune=native -m64 -pipe -DPIC -fPIC -O2 -mmmx -mfpmath=sse
-msse -msse2 -msse3 -mssse3 -msse4.1 -Wall
 -Wno-pointer-sign -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include
-I/usr/include/atk-1.0 -I/usr/include/cairo
 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/pixman-1 -I/usr/include/free
type2 -I/usr/include/libpng12   -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -pthread -I/usr/include/glib-2.0 -I
/usr/lib/glib-2.0/include   -pthread -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -pthread -I/usr/include/libgla
de-2.0 -I/usr/include/gtk-2.0 -I/usr/include/libxml2 -I/usr/lib/gtk-2.0/include
-I/usr/include/atk-1.0 -I/usr/include/cai
ro -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/pixman-1 -I/usr/include/fr
eetype2 -I/usr/include/libpng12   -pthread -I/usr/include/gpod-1.0
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I
/usr/include/gtk-2.0     -pthread -DORBIT2=1 -I/usr/include/gnome-vfs-2.0
-I/usr/lib/gnome-vfs-2.0/include -I/usr/include
/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0
-I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/
glib-2.0/include   -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/hal
-I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include   
 -z combreloc -s -Wl,-O1 -Wl,--hash-style=gnu -o gtkpod autodetection.o
charset.o clientserver.o confirmation.o context_m
enus.o date_parser.o date_parser2.o details.o display_coverart.o display.o
display_playlists.o display_sorttabs.o display
_itdb.o display_photo.o display_spl.o display_tracks.o fetchcover.o file.o
file_export.o file_convert.o file_itunesdb.o fileselection.o flacfile.o info.o
ipod_init.o main.o misc.o misc_confirm.o misc_conversion.o misc_input.o
misc_playlist.o misc_track.o mp3file.o mp4file.o oggfile.o podcast.o prefs.o
sort_window.o repository.o sha1.o stock_icons.o syncdir.o tools.o wavfile.o
help.o prefsdlg.o infodlg.o rb_rating_helper.o rb_cell_renderer_rating.o -lFLAC
-lvorbisfile -lmp4v2 -lid3tag  -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0
-lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0
-lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt
-lglib-2.0   -lglib-2.0   -Wl,--export-dynamic -pthread -lgmodule-2.0 -lrt
-lglib-2.0   -pthread -lgthread-2.0 -lrt -lglib-2.0   -pthread -lglade-2.0
-lgtk-x11-2.0 -lxml2 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0
-lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig
-lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0   -pthread -lgpod
-lgdk_pixbuf-2.0 -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0  
-lcurl   -pthread -lgnomevfs-2 -lgconf-2 -lgmodule-2.0 -lgobject-2.0
-lgthread-2.0 -lrt -lglib-2.0   -lhal -ldbus-1 -lpthread -lrt     -lFLAC
-lvorbisfile -lmp4v2 -lid3tag  -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0
-lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0
-lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt
-lglib-2.0   -lglib-2.0   -Wl,--export-dynamic -pthread -lgmodule-2.0 -lrt
-lglib-2.0   -pthread -lgthread-2.0 -lrt -lglib-2.0   -pthread -lglade-2.0
-lgtk-x11-2.0 -lxml2 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0
-lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig
-lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0   -pthread -lgpod
-lgdk_pixbuf-2.0 -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0  
-lcurl   -pthread -lgnomevfs-2 -lgconf-2 -lgmodule-2.0 -lgobject-2.0
-lgthread-2.0 -lrt -lglib-2.0   -lhal -ldbus-1 -lpthread -lrt
mp4file.o: In function `mp4_write_file_info':
mp4file.c:(.text+0x8f): undefined reference to `MP4GetMetadataBPM'
mp4file.c:(.text+0x144): undefined reference to `MP4SetMetadataComposer'
mp4file.c:(.text+0x18f): undefined reference to `MP4SetMetadataReleaseDate'
mp4file.c:(.text+0x1f3): undefined reference to `MP4SetMetadataBPM'
mp4file.c:(.text+0x30b): undefined reference to `MP4SetMetadataBPM'
mp4file.o: In function `mp4_get_file_info':
mp4file.c:(.text+0xa99): undefined reference to `MP4GetMetadataComposer'
mp4file.c:(.text+0xb03): undefined reference to `MP4GetMetadataReleaseDate'
mp4file.c:(.text+0xc56): undefined reference to `MP4GetMetadataBPM'
collect2: ld returned 1 exit status
make[2]: *** [gtkpod] Error 1
make[2]: Leaving directory `/usr/src/gtkpod-0.99.14/src'
make[1]: Leaving directory `/usr/src/gtkpod-0.99.14'
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list