[SM-Grimoire-Bugs] [Bug 15660] New: gnash 0.8.7 fails to compile

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Sun Apr 11 07:48:31 EDT 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15660

           Summary: gnash 0.8.7 fails to compile
           Product: Codex
           Version: test grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: http
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: catnap at luukku.com


The gnash spell (0.8.7) in test grimoire fails to compile. Looks to me like
gnash cannot find xulrunner ( error: nscore.h: No such file or directory ), and
so it fails to build the plugin for Mozilla browsers ( make[3]: *** [plugin.lo]
Error 1 ).

# locate nscore.h
/usr/include/xulrunner-1.9/nscore.h

# gaze version xulrunner
Grimoire  Section  Spell      Grimoire Version  Installed Version
--------  -------  -----      ----------------  -----------------
test      http     xulrunner  1.9.2.3           1.9.2.3


The last output when casting gnash is this:

libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I.. -DPLUGIN_TRACE -DXP_UNIX
-DMOZ_X11 -DGNASHBINDIR=\"/usr/bin\" -DSYSCONFDIR=\"/etc\" -I../libcore
-I../libcore/parser -I../libbase -I../backend -I./mozilla-sdk
-I./mozilla-sdk/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread
-I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
-I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2
-I/usr/include/libpng12 -I/usr/include/cairo -I/usr/include/pixman-1
-I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-pthread -I/usr/include/atk-1.0 -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -pthread -I/usr/include/pango-1.0
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -march=prescott -pipe -O2
-W -Wall -Wcast-align -Wcast-qual -Wpointer-arith -Wreturn-type
-Wnon-virtual-dtor -Wunused -fvisibility-inlines-hidden -MT plugin.lo -MD -MP
-MF .deps/plugin.Tpo -c plugin.cpp  -fPIC -DPIC -o .libs/plugin.o
plugin.cpp:90:21: error: nscore.h: No such file or directory
plugin.cpp:91:26: error: nsISupports.h: No such file or directory
plugin.cpp:92:34: error: nsIExtensionManager.h: No such file or directory
plugin.cpp:93:22: error: nsIFile.h: No such file or directory
plugin.cpp:94:22: error: nsXPCOM.h: No such file or directory
plugin.cpp:95:32: error: nsIServiceManager.h: No such file or directory
plugin.cpp:96:24: error: nsICookie.h: No such file or directory
plugin.cpp:97:31: error: nsICookieManager.h: No such file or directory
plugin.cpp:98:34: error: nsISimpleEnumerator.h: No such file or directory
plugin.cpp:99:23: error: nsNetCID.h: No such file or directory
plugin.cpp:100:23: error: nsCOMPtr.h: No such file or directory
plugin.cpp:101:26: error: nsStringAPI.h: No such file or directory
plugin.cpp:118: error: expected initializer before '*' token
plugin.cpp: In function 'NPError NS_PluginInitialize()':
plugin.cpp:168: error: 'cookieManager' was not declared in this scope
plugin.cpp:169: error: 'nsIServiceManager' was not declared in this scope
plugin.cpp:169: error: 'serviceManager' was not declared in this scope
plugin.cpp:169: error: 'nsnull' was not declared in this scope
plugin.cpp:182: error: 'nsresult' was not declared in this scope
plugin.cpp:182: error: expected `;' before 'rv'
plugin.cpp:183: error: 'rv' was not declared in this scope
plugin.cpp:183: error: 'NS_COOKIEMANAGER_CONTRACTID' was not declared in this
scope
plugin.cpp:184: error: 'nsICookieManager' was not declared in this scope
plugin.cpp:184: error: 'NS_GET_IID' was not declared in this scope
plugin.cpp:186: error: 'NS_FAILED' was not declared in this scope
make[3]: *** [plugin.lo] Error 1
make[3]: Leaving directory `/usr/src/gnash-0.8.7/plugin'
make[2]: Leaving directory `/usr/src/gnash-0.8.7/plugin'
make[1]: Leaving directory `/usr/src/gnash-0.8.7'
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
 ! Problem Detected ! 
Creating compile log /var/log/sorcery/compile/gnash-0.8.7.bz2 
Creating castfs debug log
/var/log/sorcery/compile/gnash-0.8.7.castfs.dbglog.bz2 

Spells that encountered problems:
---------------------------------
gnash


And here are the choices I gave to cast:

# cast -r gnash
Computing previously installed dependencies...
gnash preparing environment...
gnash running configuration...
Which shared memory type do you want to use?
    (0)  sysv
    (1)  posix

Which one do you want? [0] 

Enable Cygnal server [n] 

Enable CGIs for Cygnal [n] 

Makes the plugin write the currently playing SWF to /tmp. [y] 

Which GUI do you want to use?
    (0)  GTK
    (1)  KDE
    (2)  KDE4

Which one do you want? [0] 

Which media backend do you want to use?
    (0)  gstreamer
    (1)  ffmpeg
    (2)  none

Which one do you want? [0] 

Which renderer to use?
    (0)  cairo
    (1)  opengl
    (2)  agg

Which one do you want? [0] 

gnash checking dependencies...
gnash has a dependency on boost
gnash requests boost with THREAD
gnash requests boost with DATE_TIME
gnash has a dependency on curl
gnash has a dependency on fontconfig
gnash has a dependency on g++
gnash has a dependency on jpeg
gnash has a dependency on libpng
gnash has a dependency on libxml2
gnash has a dependency on zlib
gnash has a dependency on cairo
gnash has a dependency on gstreamer
gnash has a dependency on atk
gnash has a dependency on some GTK2.
    (0)    gtk+2     (installed)
    (1)    gtk+2-directfb

Which one do you want? [0] 

gnash has a dependency on gtkglext
gnash has a dependency on pango
gnash has a suggested dependency on some NS-PLUGIN-COMPATIBLE (Suggested to run
the plugin from a browser).
    (0)    [none]
    (1)    firefox     (installed)
    (2)    firefox-bin
    (3)    firefox-obstcp
    (4)    icecat
    (5)    icecat-bin
    (6)    kdebase
    (7)    kdebase4
    (8)    midori     (installed)
    (9)    opera
    (a)    seamonkey     (installed)
    (b)    seamonkey-bin
    (c)    xulrunner     (installed)
    (d)    xulrunner-bin

Which one do you want? [1] c
gnash has an optional dependency on nspr (Enable support for Netscape Portable
Runtime (NSPR))
Do you want to use nspr? [y] 

gnash has an optional dependency on libxft (Enable support for xft library)
Do you want to use libxft? [y] 

gnash has an optional dependency on dbus (for D-bus extension support)
Do you want to use dbus? [y] 

gnash has an optional dependency on gettext (for Native Language Support)
Do you want to use gettext? [y] 

gnash has an optional dependency on lirc (for Linux infra-red controller
support)
Do you want to cast lirc? [n] 

gnash has an optional dependency on some GECKO (Enable xpcom support in NPAPI
plugin).
    (0)    [none]
    (1)    icecat
    (2)    seamonkey     (installed)
    (3)    xulrunner     (installed)
    (4)    xulrunner-bin

Which one do you want? [2] 3
gnash has an optional dependency on giflib (Enable support for gif images.)
Do you want to use giflib? [y] 

gnash has an optional dependency on expat (Enable support for Expat library.)
Do you want to use expat? [y] 

gnash has an optional dependency on docbook-utils (Enable support for building
documentation)
Do you want to cast docbook-utils? [n] 

gnash has an optional dependency on libssh (Enable using SSH for network
communication)
Do you want to cast libssh? [n] 

gnash has an optional dependency on openssl (Enable using OpenSSL directly)
Do you want to use openssl? [y] 

gnash has an optional dependency on python (Enable python wrapper support)
Do you want to use python? [y] 

boost No work to do.
curl No work to do.
fontconfig No work to do.
g++ No work to do.
jpeg No work to do.
libpng No work to do.
libxml2 No work to do.
zlib No work to do.
cairo No work to do.
gstreamer No work to do.
atk No work to do.
gtk+2 No work to do.
gtkglext No work to do.
pango No work to do.
nspr No work to do.
libxft No work to do.
dbus No work to do.
gettext No work to do.
xulrunner No work to do.
giflib No work to do.
expat No work to do.
openssl No work to do.
python No work to do.
Collating dependencies...
Spells are to be cast:
---------------------------
gnash

Do you want to cast these spells? [y]


Enabling python wrapper support for gnash requires installing pygtk2, which
seems to be a missing dependency in the gnash spell. But the actual problem is
that I cannot install gnash 0.8.7 because the compile fails, as described
above.

Please try if you can reproduce this problem to confirm if it is a bug.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list