[SM-Grimoire-Bugs] [Bug 15656] New: pycups 1.9.49 fails to find declared VERSION during install

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Apr 9 14:43:40 EDT 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15656

           Summary: pycups 1.9.49 fails to find declared VERSION during
                    install
           Product: Codex
           Version: stable-rc grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: printer
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org


# Computing previously installed dependencies...
pycups preparing environment...
pycups checking dependencies...
pycups has a dependency on python
pycups has a dependency on cups
...
running build_ext
building 'cups' extension
gcc -pthread -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -march=native
-mt
une=native -m64 -pipe -DPIC -fPIC -O2 -fPIC -I/usr/include/python2.6 -c
cupsmodu
le.c -o build/temp.linux-x86_64-2.6/cupsmodule.o
cupsmodule.c: In function 'cups_require':
cupsmodule.c:389: error: 'VERSION' undeclared (first use in this function)
cupsmodule.c:389: error: (Each undeclared identifier is reported only once
cupsmodule.c:389: error: for each function it appears in.)
cupsmodule.c:424: error: expected ')' before 'VERSION'
error: command 'gcc' failed with exit status 1
make: *** [install] Error 1

$ gaze version python cups
Grimoire  Section  Spell   Grimoire Version  Installed Version
--------  -------  -----   ----------------  -----------------
test      gnu      gcc     4.4.3             4.4.3
test      gnu      g++     4.4.3             4.4.3
test      devel    python  2.6.5             2.6.5
test      printer  cups    1.4.3             1.4.3

$ cat /etc/sorcery/local/depends/cups.p 
CUPS_VER="stable"
EXTRA_LANG="n"
CUPS_PDF="none"
CUPS_OPTS="--enable-pap --enable-use-network-default --disable-raw-printing"
INIT_INSTALLED=""
INIT_NOT_INSTALLED="cups"
INIT_ENABLED=""
INIT_DISABLED=""
XINETD_INSTALLED=""
XINETD_NOT_INSTALLED="cups-lpd"
XINETD_ENABLED=""
XINETD_DISABLED=""

$ cat /etc/sorcery/local/depends/python.p 
PYTHON_OPTS="--enable-ipv6 --with-threads --with-pth"

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list