[SM-Grimoire-Bugs] [Bug 15630] glib2 pcre optional_depends doesn't work

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Wed Apr 7 15:05:33 EDT 2010


http://bugs.sourcemage.org/show_bug.cgi?id=15630





--- Comment #5 from Eric Sandall <sandalle at sourcemage.org>  2010-04-07 14:05:32 ---
# scribe rem stable; scribe add stable-rc; sorcery queue; cast --queue
...
glib2 has an optional dependency on some FAM (Build with file system
monitoring).
        (0)     [none]
        (1)     fam
        (2)     gamin

Which one do you want? [0] 2
glib2 has an optional dependency on pcre (Use system supplied PCRE. Otherwise,
the internal PCRE library will be used)
Do you want to use pcre? [y] 

glib2 requests pcre with UTFPROP
bogus sub_depends: pcre UTFPROP

$ cat /var/lib/sorcery/codex/stable-rc/libs/pcre/SUB_DEPENDS 
case "$THIS_SUB_DEPENDS" in
  UTFPROP) message "pcre with UTF-8 properties requested, forcing support" &&
           BUILDUTF8=y &&
           UTFPROPERTIES=y &&
           persistent_add UTFPROPERTIES ;;
  CPP) depends g++ "--enable-cpp" ;;
    *) echo "bogus sub_depends: pcre $THIS_SUB_DEPENDS"; return 1;;
esac

$ cat /var/lib/sorcery/codex/stable-rc/libs/pcre/PRE_SUB_DEPENDS
case "$THIS_SUB_DEPENDS" in
  UTFPROP) if [[ $BUILDUTF8 == y ]] &&
              [[ $UTFPROPERTIES == y ]]; then return 0; else return 1; fi ;;
  CPP) is_depends_enabled $SPELL g++ ;;
    *)  echo "bogus sub_depends: pcre $THIS_SUB_DEPENDS"; return 1;;
esac

$ cat
/var/lib/sorcery/codex/stable-rc/libs/pcre/REPAIR^f759b166c7ff34012ab85e9c6742315f^PRE_SUB_DEPENDS
case "$THIS_SUB_DEPENDS" in
  UTFPROP) if [[ $BUILDUTF8 == y ]] &&
              [[ $UTFPROPERTIES == y ]]; then return 0; else return 1; fi ;;
  CPP) is_depends_enabled $SPELL g++ ;;
    *)  echo "bogus sub_depends: pcre $THIS_SUB_DEPENDS"; return 1;;
esac

$ git revert c5d9b2170ad60ea3a051d37562ec546dd288f433
[master be899b6] Revert "pcre: added sub dependency support for UTF8
properties"
 4 files changed, 0 insertions(+), 17 deletions(-)
 delete mode 100755
libs/pcre/REPAIR^f759b166c7ff34012ab85e9c6742315f^PRE_SUB_DEPENDS

$ md5sum PRE_SUB_DEPENDS 
f759b166c7ff34012ab85e9c6742315f  PRE_SUB_DEPENDS

$ cat /var/lib/sorcery/codex/stable-rc/VERSION 
0.43-rc
a6693bf363907caabd1d83f442b821bda9a306e3

Does scribe not update the tablet when updating/changing grimoires?

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list