[SM-Grimoire-Bugs] [Bug 15242] New: evolution-exchange 2.26.2 fails to compile with LDFLAGS=-Wl, --as-needed

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Thu May 28 22:39:51 EDT 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15242

           Summary: evolution-exchange 2.26.2 fails to compile with
                    LDFLAGS=-Wl,--as-needed
           Product: Codex
           Version: stable grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: minor
          Priority: P3
         Component: gnome2-libs
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org
            Blocks: 15215



Eric Sandall <sandalle at sourcemage.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
               Flag|                            |must_fix_before_release-


$ gaze version gcc glibc binutils
Grimoire  Section  Spell     Grimoire Version  Installed Version
--------  -------  -----     ----------------  -----------------
test      gnu      gcc       4.3.3             4.3.3
test      libs     glibc     2.10.1            2.10.1
test      devel    binutils  2.19.1            2.19.1

$ sorcery -v
1.14.4-rc2

# cast evolution-exchange
...
libtool: link: gcc -march=core2 -fPIC -DPIC -pipe -DPIC -fPIC -O2 -Wall
-Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare
-Wno-sign-compare -z combreloc -s -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed
-o migr-test migr-test.o exchange-config-listener.o exchange-migrate.o
-Wl,-R/usr/lib/evolution/2.26 -pthread -Wl,-R/usr/lib/evolution/2.26 -pthread 
-L/usr/lib64 -L/usr/lib -L/usr/lib/evolution/2.26 -L/lib
/usr/lib/libedata-book-1.2.so /usr/lib/libedata-cal-1.2.so
/usr/lib/libecal-1.2.so /usr/lib/libicalss.so /usr/lib/libicalvcal.so
/usr/lib/libical.so /usr/lib/evolution/2.26/libeshell.so
/usr/lib/evolution/2.26/libemiscwidgets.so /usr/lib/evolution/2.26/libetext.so
/usr/lib/evolution/2.26/libetable.so
/usr/lib/evolution/2.26/libevolution-widgets-a11y.so
/usr/lib/evolution/2.26/libevolution-a11y.so
/usr/lib/evolution/2.26/libeutil.so /usr/lib/libcamel-provider-1.2.so
/usr/lib/libgtkhtml-editor.so /usr/lib/libgtkhtml-3.14.so
/usr/lib/libenchant.so /usr/lib/libgnomeui-2.so /usr/lib/libbonoboui-2.so
/usr/lib/libSM.so -luuid /usr/lib/libICE.so /usr/lib/libgnomecanvas-2.so
/usr/lib/libgailutil.so /usr/lib/libXinerama.so /usr/lib/libXrandr.so
/usr/lib/libXcursor.so /usr/lib/libXcomposite.so /usr/lib/libXext.so
/usr/lib/libXdamage.so /usr/lib/libXfixes.so /usr/lib/libgnome-2.so
/usr/lib/libgnomevfs-2.so -lutil /usr/lib/libpopt.so /usr/lib/libart_lgpl_2.so
/usr/lib/libedataserverui-1.2.so /usr/lib/libebook-1.2.so
/usr/lib/libcamel-1.2.so /usr/lib/libsqlite3.so -lssl3 -lsmime3 -lnss3
-lsoftokn3 /usr/lib/libebackend-1.2.so /usr/lib/libexchange-storage-1.2.so
-lkrb5 -lk5crypto -lcom_err /usr/lib/libedataserver-1.2.so
/usr/lib/libbonobo-2.so /usr/lib/libbonobo-activation.so
/usr/lib/libORBitCosNaming-2.so -lplc4 -lplds4 -lnspr4 /usr/lib/libglade-2.0.so
/usr/lib/libgtk-x11-2.0.so /usr/lib/libgdk-x11-2.0.so /usr/lib/libatk-1.0.so
/usr/lib/libgdk_pixbuf-2.0.so /usr/lib/libpangocairo-1.0.so
/usr/lib/libpangoft2-1.0.so /usr/lib/libcairo.so /usr/lib/libpixman-1.so
/usr/lib/libglitz.so /usr/lib/libpng12.so /usr/lib/libXrender.so
/usr/lib/libX11.so /usr/lib/libxcb.so /usr/lib/libXau.so /usr/lib/libXdmcp.so
/usr/lib/libpango-1.0.so /usr/lib/libfontconfig.so /usr/lib/libfreetype.so
/usr/lib/libexpat.so /usr/lib/libgconf-2.so /usr/lib/libORBit-2.so
/usr/lib/libdbus-glib-1.so /usr/lib/libgnome-keyring.so /usr/lib/libdbus-1.so
/usr/lib/libldap.so /usr/lib/libsasl2.so -lgssapi_krb5 -lssl -lcrypto
/usr/lib/liblber.so -lresolv -lnsl /usr/lib/libsoup-2.4.so
/usr/lib/libgthread-2.0.so -lpthread -lrt /usr/lib/libxml2.so -lm
/usr/lib/libgnutls.so /usr/lib/libtasn1.so -lz /usr/lib/libgcrypt.so
/usr/lib/libgpg-error.so /usr/lib/libgio-2.0.so /usr/lib/libgobject-2.0.so
/usr/lib/libgmodule-2.0.so -ldl /usr/lib/libglib-2.0.so -pthread -Wl,-rpath
-Wl,/usr/lib/evolution/2.26 -Wl,-rpath -Wl,/usr/lib/evolution/2.26
/usr/lib/libexchange-storage-1.2.so: undefined reference to
`e_passwords_remember_password'
/usr/lib/libexchange-storage-1.2.so: undefined reference to
`e_passwords_get_password'
/usr/lib/libexchange-storage-1.2.so: undefined reference to
`e_passwords_forget_password'
/usr/lib/libexchange-storage-1.2.so: undefined reference to
`e_passwords_add_password'
/usr/lib/libexchange-storage-1.2.so: undefined reference to
`e_passwords_ask_password'
collect2: ld returned 1 exit status
make[2]: Leaving directory `/usr/src/evolution-exchange-2.26.2/storage'
make[2]: *** [migr-test] Error 1
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/evolution-exchange-2.26.2'
make: *** [all] Error 2

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list