[SM-Grimoire-Bugs] [Bug 15228] New: subversion seems to require sqlite

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri May 15 09:30:32 EDT 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15228

           Summary: subversion seems to require sqlite
           Product: Codex
           Version: stable grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: collab
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: wich at stack.nl


Trying to cast subversion from stable without sqlite installed gives:

configure: checking sqlite library                                              
amalgamation not found at
/usr/src/subversion-1.6.0/sqlite-amalgamation/sqlite3.
c
checking sqlite3.h usability... no
checking sqlite3.h presence... no
checking for sqlite3.h... no
checking sqlite library version (via pkg-config)... no

An appropriate version of sqlite could not be found.  We recommmend
3.6.11, but require at least 3.4.0.
Please either install a newer sqlite on this system

or

get the sqlite 3.6.11 amalgamation from:
    http://www.sqlite.org/sqlite-amalgamation-3.6.11.tar.gz
unpack the archive using tar/gunzip and copy sqlite3.c from the
resulting directory to:
/usr/src/subversion-1.6.0/sqlite-amalgamation/sqlite3.c
This file also ships as part of the subversion-deps distribution.

configure: error: Subversion requires SQLite

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list