[SM-Grimoire-Bugs] [Bug 15217] New: ffmpeg 0.5 fails to compile with LDFLAGS=-Wl, --as-needed

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Sat May 9 18:43:56 EDT 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15217

           Summary: ffmpeg 0.5 fails to compile with
                    LDFLAGS=-Wl,--as-needed
           Product: Codex
           Version: test grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: video
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org
            Blocks: 15215


$ gaze version gcc glibc binutils
Grimoire  Section  Spell     Grimoire Version  Installed Version
--------  -------  -----     ----------------  -----------------
test      gnu      gcc       4.3.3             4.3.3
test      libs     glibc     2.9               2.9
test      devel    binutils  2.19.1            2.19.1

$ sorcery -v
1.14.2
# cast ffmpeg
...
Unpacking source file ffmpeg-0.5.tar.bz2 for spell ffmpeg.
Using gcc version: 4.3.3
Installing in dir: /usr/src/ffmpeg-0.5
ffmpeg    0.5
ERROR: libxvid not found
If you think configure made a mistake, make sure you are using the latest
version from SVN.  If the latest version fails, report the problem to the
ffmpeg-user at mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.err" produced by configure as this will help
solving the problem.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list