[SM-Grimoire-Bugs] [Bug 15138] New: webkitgtk -> libsoup -> libproxy -> webkitgtk circular dependency

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Tue Mar 24 18:46:37 EDT 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15138

           Summary: webkitgtk -> libsoup -> libproxy -> webkitgtk circular
                    dependency
           Product: Codex
           Version: test grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: gnome2-libs
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org
        Depends on: 15103
            Blocks: 15136


When building webkitgtk 1.1.3, it requires devel version of libsoup (Bug
#15103) which depends on libproxy which optionally uses webkitgtk.

(Need to cast libsoup to enable devel version)

$ sorcery -v
1.14.3-rc3

# cast webkitgtk libsoup
Computing previously installed dependencies...
webkitgtk preparing environment...
[[ Build recent nightly build? -> n ]]
webkitgtk running configuration...
[[ Select font backend to use -> 'pango' ]]
[[ Enable SVG support? -> y ]]
webkitgtk checking dependencies...
webkitgtk has a dependency on g++
webkitgtk has a dependency on autoconf
webkitgtk has a dependency on automake
webkitgtk has a dependency on libtool
webkitgtk has a dependency on gtk+2
webkitgtk has a dependency on icu
webkitgtk has a dependency on gperf
webkitgtk has a dependency on libpng
webkitgtk has a dependency on jpeg
webkitgtk has a dependency on bison
webkitgtk has a dependency on flex
webkitgtk has a dependency on sqlite
webkitgtk has a dependency on libxslt
webkitgtk has a dependency on libsoup
webkitgtk has a dependency on pango
webkitgtk checking for reverse triggers
libsoup preparing environment...
[[ Build devel version of libsoup? -> y ]]
libsoup running configuration...
[[ Build with gnome support? -> y ]]
libsoup checking dependencies...
libsoup has a dependency on autoconf
libsoup has a dependency on automake
libsoup has a dependency on libtool
libsoup has a dependency on libxml2
libsoup has a dependency on glib2
libsoup has a dependency on libgpg-error
libsoup has a dependency on libproxy
libsoup has a dependency on gconf2
libsoup has an enabled optional dependency on gnutls
libsoup has a disabled optional dependency on gtk-doc
...
libproxy preparing environment...
libproxy running configuration...
[[ Do you want to build gnome config plugin? -> y ]]
[[ Do you want to build kde config plugin? -> y ]]
libproxy checking dependencies...
libproxy has a dependency on libxmu
libproxy has a dependency on gconf2
libproxy has a dependency on libxmu
libproxy has an optional dependency on python (for Python bindings)
Do you want to use python? [y]
libproxy has an optional dependency on webkitgtk (Build WebKit JavaScriptCore
PAC plugin)
Do you want to cast webkitgtk? [y]
...
Spells are to be cast:
---------------------------
libproxy                        libsoup         webkitgtk

Do you want to cast these spells? [y]
...
Unpacking source file libsoup-2.25.91.tar.bz2 for spell libsoup.
...
checking for LIBPROXY... no
configure: error: Could not find libproxy:

No package 'libproxy-1.0' found

libproxy is now a dependency of GNOME, and is required for proxy
support in libsoup.

Pass "--without-gnome" to configure if you want to build libsoup
without GNOME support.

Spells that have been dropped:
------------------------------
libproxy        libsoup


Spells that encountered problems:
---------------------------------
webkitgtk

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list