[SM-Grimoire-Bugs] [Bug 15104] libxcb 1.2 renames shared objects and loses the library archive breaking many packages

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Tue Mar 24 11:29:38 EDT 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15104





--- Comment #23 from David Kowis <dkowis at shlrm.org>  2009-03-24 10:29:36 ---
(In reply to comment #22)
> (In reply to comment #14)
> > This works for me:
> > 
> > find /usr/lib -name "*.la" -exec sed -e "s:-lxcb-xlib:: ;
> > s:/usr/lib/libxcb-xlib.la::" -i \{\} \;
> > 
> > (see http://bugs.gentoo.org/158476)
> 
> similar problem with gtk+2 and /usr/lib/libxcb-render-util.la
> 
> find /usr/lib -name "*.la" -exec sed -e \
> "s:/usr/lib/libxcb-render-util.la::" -i.libxcb-render-util.la \{\} \;
> 
> stability to be determined..

My box seems to be quite satisfied after blowing away all this stuff. A cleanse
--fix fixed everything and there's no more problems.

We've got some significant issues here to resolve:

It has been suggested that we kill the files libtool creates, as more often
than not, they cause more problems than they solve (with the exceptions of the
spells that need them [kde stuff apparently]).

Then the one time hax fix to remove libxcb-xlib from all the libtool files
(because it shouldn't be there anyway)...

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list