[SM-Grimoire-Bugs] [Bug 15257] New: Migration of libblkid.so from e2fsprogs to util-linux breaks mount/boot

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Jun 12 17:41:36 EDT 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15257

           Summary: Migration of libblkid.so from e2fsprogs to util-linux
                    breaks mount/boot
           Product: Codex
           Version: test grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: blocker
          Priority: P3
         Component: libs
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org
                CC: hgr at vabo.cz


Upgrading from util-linux 2.14.2 to 2.15 and switching libblkid.so from
e2fsprogs to util-linux causes machines to be unbootable.

Caused by the following two commits:
commit 1e47209c76d71e77929f8a407b491e7c21792e5c
Author: Ladislav Hagara <hgr at vabo.cz>
Date:   Tue May 12 19:43:24 2009 +0200

    util-linux: blkid is provided by util-linux instead of e2fsprogs from now

commit 04dda0b8397fc7d6624bba125deaff57a257eed6
Author: Ladislav Hagara <hgr at vabo.cz>
Date:   Tue May 12 19:36:11 2009 +0200

    e2fsprogs: blkid is provided by util-linux instead from e2fsprogs from now

Some discovery:
commit 784fc35b1253cd8c6f15184d96a7daa4972453b5
Author: Eric Sandall <sandalle at sourcemage.org>
Date:   Wed May 13 01:29:40 2009 -0700

    Revert "e2fsprogs: Depends on util-linux for blkid"

    This reverts commit c3ff13022ef5564b2c6dbc28226532ec7ee39a34.

    I'm not sure what's going on, but putting the dependency order correct
    breaks.

    e2fsprogs 1.41.4 used to provide blkid.
    util-linux 2.15 now provides blkid.
    e2fsprogs 1.41.5 requires blkid from util-linux 2.15

    e2fsprogs 1.41.5 no longer provides blkid and needs it from util-linux.
    util-linux 2.15 cannot compile without e2fsprogs.

    Currently:
    update e2fsprogs from 1.41.4 -> 1.41.5, removing libblkid.so.
        mount (from util-linux) now fails as it cannot find libblkid.so.1.
    update util-linux to 2.15, now providing libblkid.so.
        mount is happy.
    e2fsprogs is built with its old libblkid.so and seems to still be happy.
    with util-linux's libblkid.so as they are ABI compatible (just moved
    packages, AFAIK).

    After this fun switch:
    e2fsprogs will need to be cast after util-linux, since future updates to
    libblkid.so will come from util-linux and are required by e2fsprogs.

    Possible resolution:
    Leave in current state (as above) and only fix the dependencies after
    this switch has been in a few stable releases.

May be caused only if using castfs as during PRE_INSTALL of
e2fsprogs/util-linux libblkid.so is removed, but then needed by castfs to mount
and do INSTALL, leaving no libblkid.so available for mount to use and making a
system unbootable.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list