[SM-Grimoire-Bugs] [Bug 15256] New: subversion 1.6.2 fails to find Berkeley DB

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Jun 12 17:24:40 EDT 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15256

           Summary: subversion 1.6.2 fails to find Berkeley DB
           Product: Codex
           Version: test grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: collab
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org


$ sorcery -v
1.14.4-rc2

$ gaze version apr apr-util subversion db
Grimoire  Section   Spell       Grimoire Version  Installed Version
--------  -------   -----       ----------------  -----------------
test      libs      apr         1.3.5             1.3.5
test      libs      apr-util    1.3.7             1.3.7
test      collab    subversion  1.6.2             1.6.2
test      database  db          4.7.25            4.7.25

==> /etc/sorcery/local/depends/subversion.p <==
SVN_HEAD="n"
SVN_PERL="y"
SVN_PYTHON="y"
SVN_RUBY="n"
XINETD_INSTALLED=""
XINETD_NOT_INSTALLED="svnserve"
XINETD_ENABLED=""
XINETD_DISABLED=""

# cast subversion
Computing previously installed dependencies...
subversion preparing environment...
[[ Download latest Subversion source code? -> n ]]
subversion running configuration...
[[ Install Subversion bindings for Perl? -> y ]]
[[ Install Subversion bindings for Python? -> y ]]
[[ Install Subversion bindings for Ruby? -> n ]]
Install xinetd script svnserve? [n] 
subversion checking dependencies...
subversion has a dependency on sqlite
subversion has a dependency on some APR.
Continue to use apr? [y] 
subversion has a dependency on some APU.
Continue to use apr-util? [y] 
subversion has a dependency on autoconf
subversion has a dependency on bison
subversion has a dependency on e2fsprogs
subversion has a dependency on libtool
subversion has a dependency on swig
subversion has a dependency on perl
subversion has a dependency on python
subversion has an enabled optional dependency on zlib
subversion has an enabled optional dependency on gettext
subversion has an enabled optional dependency on openssl
subversion has an enabled optional dependency on cyrus-sasl
WARNING, disabling neon is not recommended and may break downloading some svn
spells.
subversion has an enabled optional dependency on neon
subversion has an enabled optional dependency on db
subversion has an optional dependency on some APACHE2 (to create Apache 2
modules).
Continue to use [none]? [y]
...
checking for trang... none
checking for socket in -lsocket... no
checking for availability of Berkeley DB... no
configure: error: Berkeley DB 4.0.14 or newer wasn't found.

Fails on:
Computer1:
$ grep HEADERS /etc/sorcery/local/depends/glibc.p
GLIBC_HEADERS_DIR="/usr/src/glibc-2.10.1/linux-2.6.30"
GLIBC_SANITIZE_HEADERS="y"

--------------------{Section:     COMPILER CONFIG}--------------------
SMGL_COMPAT_ARCHS=32/ia32/intel/em64t/core2_32/
ARCHITECTURE="core2_32"
OPTIMIZATIONS="combreloc prelink strip "
CUSTOM_CFLAGS="-O2"
CUSTOM_CXXFLAGS="-O2"
CUSTOM_LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
CFLAGS="-march=core2 -m32 -mmmx -mfpmath=sse -msse -msse2 -msse3 -mssse3 -pipe
-DPIC -fPIC -O2"
CXXFLAGS="-march=core2 -m32 -mmmx -mfpmath=sse -msse -msse2 -msse3 -mssse3
-pipe -DPIC -fPIC -O2"
LDFLAGS="-z combreloc -s -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
HOST="i686-pc-linux-gnu"
CCACHE="on"
DISTCC_HOSTS=""
JOBS_PER_HOST="1"
MAKE_NJOBS="2"

Computer2:
$ grep HEADERS /etc/sorcery/local/depends/glibc.p
GLIBC_SANITIZE_HEADERS="n"
GLIBC_HEADERS_DIR="/usr/src/glibc-2.10.1/linux-2.6.30"

--------------------{Section:     COMPILER CONFIG}--------------------
SMGL_COMPAT_ARCHS=64/x86_64/intel/em64t/core2_64/
ARCHITECTURE="core2_64"
OPTIMIZATIONS="combreloc prelink strip "
CUSTOM_CFLAGS="-O2"
CUSTOM_CXXFLAGS="-O2"
CUSTOM_LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu"
CFLAGS="-march=core2 -fPIC -DPIC -pipe -DPIC -fPIC -O2"
CXXFLAGS="-march=core2 -fPIC -DPIC -pipe -DPIC -fPIC -O2"
LDFLAGS="-z combreloc -s -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
HOST="x86_64-pc-linux-gnu"
CCACHE="on"
DISTCC_HOSTS=""
JOBS_PER_HOST="1"
MAKE_NJOBS="2"

Computer3:
$ grep HEADERS /etc/sorcery/local/depends/glibc.p
GLIBC_SANITIZE_HEADERS="n"
GLIBC_HEADERS_DIR="/usr/src/glibc-2.10.1/linux-2.6.30"

--------------------{Section:     COMPILER CONFIG}--------------------
SMGL_COMPAT_ARCHS=64/x86_64/intel/em64t/core2_64/
ARCHITECTURE="core2_64"
OPTIMIZATIONS="combreloc prelink strip "
CUSTOM_CFLAGS="-O2"
CUSTOM_CXXFLAGS="-O2"
CUSTOM_LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
CFLAGS="-march=core2 -fPIC -DPIC -mmmx -mfpmath=sse -msse -msse2 -msse3 -mssse3
-pipe -DPIC -fPIC -O2"
CXXFLAGS="-march=core2 -fPIC -DPIC -mmmx -mfpmath=sse -msse -msse2 -msse3
-mssse3 -pipe -DPIC -fPIC -O2"
LDFLAGS="-z combreloc -s -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
HOST="x86_64-pc-linux-gnu"
CCACHE="on"
DISTCC_HOSTS=""
JOBS_PER_HOST="1"
MAKE_NJOBS="2"

Works fine on:
Computer4:
$ grep HEADERS /etc/sorcery/local/depends/glibc.p 
GLIBC_SANITIZE_HEADERS="y"
GLIBC_HEADERS_DIR="/usr/src/glibc-2.10.1/linux-2.6.29"

--------------------{Section:     COMPILER CONFIG}--------------------
SMGL_COMPAT_ARCHS=32/ia32/amd/k7/athlon-xp/
ARCHITECTURE="athlon-xp"
OPTIMIZATIONS="combreloc prelink strip "
CUSTOM_CFLAGS="-O2"
CUSTOM_CXXFLAGS="-O2"
CUSTOM_LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
CFLAGS="-march=athlon-xp -mmmx -mfpmath=sse -msse -m3dnow -pipe -DPIC -fPIC
-O2"
CXXFLAGS="-march=athlon-xp -mmmx -mfpmath=sse -msse -m3dnow -pipe -DPIC -fPIC
-O2"
LDFLAGS="-z combreloc -s -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
HOST="i686-pc-linux-gnu"
CCACHE="on"
DISTCC_HOSTS="localhost "
JOBS_PER_HOST="1"
MAKE_NJOBS="1"

Not sure why 2.6.30 headers (only common difference) would break subversion
finding db when db compiled fine with the headers.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list