[SM-Grimoire-Bugs] [Bug 15166] gcc -> gmp -> g++ -> gcc circular dependency

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Wed Jun 10 15:18:11 EDT 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15166





--- Comment #9 from Eric Sandall <sandalle at sourcemage.org>  2009-06-10 14:18:10 ---
I'm not sure why this is happening:
gcc depends on gmp
gmp optionally depends on g++
g++ will force_depend on gcc because g++ 4.3.3 != gcc 4.4.0

So we should be getting:
gcc
  -> gmp
    -> g++
      -> gcc (forced)
        -> gmp
          -> g++
            -> ...
      -> gmp
        -> g++
          -> ...

Which should cause this order of casting, if force_depends overrides depends
and optional_depends:
gcc (forced from gmp)
  -> gmp (depended upon by g++)
     -> g++ (depends on gmp)

Though what we want, when archspecs (not this bug) or versions don't match, is:
gcc
  -> g++
    -> gmp
      -> gcc (triggered by gmp to build with gmp built with new
archspecs/version?)
      -> g++ (triggered by gmp to build with gmp built with new
archspecs/version?)

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list