[SM-Grimoire-Bugs] [Bug 15325] New: ardour2 spell fails. Combreloc problem

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Thu Jul 30 04:18:45 EDT 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15325

           Summary: ardour2 spell fails. Combreloc problem
           Product: Codex
           Version: stable grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: audio-creation
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: anthony at hillairet.org


Ardour2 spell fails claiming that combreloc is not found.
sorcery compilation options:
architecture k8_32, combreloc, speedy, strip

I tried casting with combreloc disabled and different options for ardour2 but
it is always the same problem: 

Output:
g++ -o libs/surfaces/control_protocol/libardour_cp.so -O3 -fomit-frame-pointer
-ffast-math -fstrength-reduce -pipe -DARCH_X86 -mmmx -m3dnow -march=i686 -msse
-mfpmath=sse -DUSE_XMMINTRIN -DBUILD_SSE_OPTIMIZATIONS -Wl,--export-dynamic
-pthread -shared libs/surfaces/control_protocol/basic_ui.os
libs/surfaces/control_protocol/control_protocol.os
libs/surfaces/control_protocol/smpte.os -Llibs/ardour -Llibs/midi++2 -Llibs/pbd
-lardour -lsndfile -lsigc-2.0 -lpbd -lmidi++ -lxml2 -lgobject-2.0 -lgmodule-2.0
-lgthread-2.0 -lrt -lglib-2.0 -lglibmm-2.4 -lgobject-2.0 -lsigc-2.0 -lglib-2.0
scons: *** [gtk2_ardour/ardour-2.8] Implicit dependency `combreloc' not found,
needed by target `gtk2_ardour/ardour-2.8'.
scons: building terminated because of errors.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list