[SM-Grimoire-Bugs] [Bug 15294] New: pyqt4 won't install with qt4 due to "license" issues

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Tue Jul 14 23:23:35 EDT 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15294

           Summary: pyqt4 won't install with qt4 due to "license" issues
           Product: Codex
           Version: test grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: x11-toolkits
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: benjamin.collar at gmail.com


the configure.py python script from pyqt4 checks the license and installation
type. Sourcemage installs "installation type" == "Desktop" and "license" ==
"GPL" and pyqt4 for whatever reason does not accept the Desktop installation
type with that license. Therefore, pyqt4 refuses to install.

As a local hack, I changed configure.py to accept "Desktop" and it worked fine.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list