[SM-Grimoire-Bugs] [Bug 15278] New: php 5.3.0 fails to install php.ini

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Thu Jul 2 15:39:48 EDT 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15278

           Summary: php 5.3.0 fails to install php.ini
           Product: Codex
           Version: stable-rc grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: php-pear
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org


php 5.3.0 and php-dev 6.0 both fail to find php.ini-dist to install as php.ini

This change occurs from 5.2.9 -> 5.3.0, 5.2.9 still has php.ini-dist. In 5.3.0
and 6.0 php.ini-dist is now php.ini-production.

# cast php
Computing previously installed dependencies...
php preparing environment...                  
[[ Install latest Release Candidate version? -> n ]]
[[ Install the latest alpha version? -> n ]]        
For more information on Suhosin patchset see:
http://www.hardened-php.net/suhosin/
[[ Do you want tho suhosin patchset enabled? -> n ]]                            
php running configuration...                                                    
[[ Enable PHP safe mode? -> n ]]                                                
[[ Enable sockets support? -> y ]]                                              
[[ Enable FTP support? -> y ]]                                                  
[[ Enable calendar support? -> y ]]                                             
[[ Enable perl regular expressions? -> y ]]                                     
[[ Enable pcntl support (CLI/CGI only) -> n ]]                                  
Both FastCGI and CGI can be enabled at the same time                            
[[ Enable FastCGI SAPI? -> n ]]                                                 
[[ Enable CGI SAPI? -> y ]]                                                     
[[ Enable multibyte support? -> n ]]                                            
[[ Enable the PDO driver? -> y ]]                                               
[[ Enable shmop support? -> n ]]                                                
[[ Enable soap support? -> n ]]                                                 
[[ Enable ZIP support? -> n ]]                                                  
[[ Enable System V message queues support? -> n ]]                              
[[ Enable System V semaphore support? -> n ]]                                   
[[ Enable System V shared memory support? -> n ]]                               
[[ Which Apache module to build? -> 'none' ]]                                   
[[ Which GD library to use? -> 'external' ]]                                    
[[ Would you like to support XPM image files? (requires: X11-LIBS) -> y ]]      
php checking dependencies...                                                    
php has a dependency on flex                                                    
php has a dependency on readline                                                
php has a dependency on zlib                                                    
php has a dependency on libxml2                                                 
php has a dependency on gd                                                      
php has an optional dependency on pcre (to use an external PCRE library)        
Do you want to use pcre? [y]                                                    
php has an optional dependency on some C-CLIENT (for IMAP support).             
        (0)     [none]                                                          
        (1)     c-client                                                        
        (2)     imap                                                            

Which one do you want? [0] 
php has an optional dependency on some MAIL-TRANSPORT-AGENT (for SMTP support).
        (0)     [none]                                                         
        (1)     courier                                                        
        (2)     esmtp                                                          
        (3)     exim                                                           
        (4)     msmtp                                                          
        (5)     nbsmtp                                                         
        (6)     netqmail                                                       
        (7)     postfix                                                        
        (8)     putmail                                                        
        (9)     qmail                                                          
        (a)     qwikmail                                                       
        (b)     sendmail                                                       
        (c)     ssmtp    (installed)                                           

Which one do you want? [0] 
php has an optional dependency on bzip2 (for compression support)
Do you want to use bzip2? [y]                                    
php has an optional dependency on aspell (for spelling functions)
Do you want to use aspell? [y]                                   
php has an optional dependency on mhash (for hash functions support)
Do you want to use mhash? [y]                                       
php has an optional dependency on libmcrypt (for crypto library)    
Do you want to use libmcrypt? [y]                                   
php has an optional dependency on curl (for cURL URL stream functions)
Do you want to use curl? [y]                                          
[[ Do you want to use cURL for URL streams in core PHP functions? -> y ]]
php has an optional dependency on gmp (GNU multi-precision library support)
Do you want to use gmp? [y]                                                
php has an optional dependency on openssl (for OpenSSL support)            
Do you want to use openssl? [y]                                            
php has an optional dependency on gettext (for GNU gettext support)        
Do you want to use gettext? [y]                                            
php has an optional dependency on firebird (for native Firebird support)   
Do you want to cast firebird? [n]                                          
php has an optional dependency on unixodbc (for ODBC database support)     
Do you want to use unixodbc? [y]                                           
[[ Do you also want to build the unixODBC PDO driver? -> n ]]              
php has an optional dependency on libiodbc (for ODBC database support)     
Do you want to cast libiodbc? [n]                                          
php has an optional dependency on postgresql (for native Postgresql support)
Do you want to cast postgresql? [n]                                         
php has an optional dependency on mysql (for MySQL support)                 
Do you want to use mysql? [y]                                               
[[ Do you want to use the MySQL Native Driver [mysqlnd]? (experimental) -> y ]]
[[ Do you want to build the MySQLi extension? -> n ]]                          
[[ Do you also want to build the MySQL PDO driver? -> n ]]                     
php has an optional dependency on gdbm (database routines that use extensive
hashing)
Do you want to use gdbm? [y]                                                    
php has an optional dependency on sqlite2 (for SQLite 2.x support)              
Do you want to use sqlite2? [n]                                                 
[[ Do you also want to build the SQLite 3.x PDO driver (requires: sqlite)? -> y
]]   
php has a dependency on sqlite                                                  
php has an optional dependency on mm (for sharing memory between related
processes)  
Do you want to use mm? [y]                                                      
php has an optional dependency on openldap (for LDAP support)                   
Do you want to use openldap? [n]                                                
php has an optional dependency on tidy (for HTML Tidy support)                  
Do you want to cast tidy? [n]                                                   
php has an optional dependency on libxslt (for XSLT support)                    
Do you want to use libxslt? [y]                                                 
php has an optional dependency on t1lib (for T1lib support)                     
Do you want to cast t1lib? [n]                                                  
php has an optional dependency on re2c (to regenerate PHP parsers)              
Do you want to cast re2c? [n]                                                   
php has an optional dependency on libexif (for image metadata support)          
Do you want to use libexif? [y]                                                 
php has a dependency on xorg-libs                                               
php has a dependency on libxpm                                                  
php has an optional dependency on jpeg (for JPEG support (for GD))              
Do you want to use jpeg? [y]                                                    
php has an optional dependency on libpng (for PNG support (for GD))             
Do you want to use libpng? [y]
php has an optional dependency on freetype2 (for freetype2 support)
Do you want to use freetype2? [y]
...
Installing man pages:             /usr/share/man/man1/
  page: phpize.1
  page: php-config.1
Installing header files:          /usr/include/php/
cp: cannot stat `php.ini-dist': No such file or directory
INSTALL failed!
 ! Problem Detected !
INSTALL failed!

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list