[SM-Grimoire-Bugs] [Bug 14976] notification-daemon / libnotify - casting failure

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Wed Jan 21 18:24:52 EST 2009


http://bugs.sourcemage.org/show_bug.cgi?id=14976


Eric Sandall <sandalle at sourcemage.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |sandalle at sourcemage.org




--- Comment #1 from Eric Sandall <sandalle at sourcemage.org>  2009-01-21 17:24:51 ---
Same issue here:

# cast libnotify
Computing previously installed dependencies...
libnotify preparing environment...
libnotify checking dependencies...
libnotify has a dependency on dbus-glib
libnotify has a dependency on gtk+2
libnotify has a dependency on some NOTIFICATION_DAEMON.
        (0)     notification-daemon
        (1)     notification-daemon-xfce

Which one do you want? [0] 0
...
Collating dependencies...
Spells are to be cast:
---------------------------
libnotify                               notification-daemon

Do you want to cast these spells? [y]
...
Building notification-daemon
GPG checking source file notification-daemon-0.4.0.tar.gz...
Algorithm used: sha512
Allowing new hash sha512
Checking spell level WORKS_FOR_ME
Spell level is a new allowed level
gpg signature verified!
Unpacking source file notification-daemon-0.4.0.tar.gz for spell
notification-daemon.
...
checking pkg-config is at least version 0.9.0... yes
checking for NOTIFICATION_DAEMON... yes
checking for NOTIFICATION_CAPPLET... configure: error: Package requirements
(glib-2.0 >= 2.10.0 gtk+-2.0 >= 2.10.0 libglade-2.0 gconf-2.0 libnotify dbus-1
dbus-glib-1) were not met:

No package 'libnotify' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables
NOTIFICATION_CAPPLET_CFLAGS
and NOTIFICATION_CAPPLET_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

* libnotify builds fine without a NOTIFICATION_DAEMON installed.
* notification-daemon fails without libnotify installed
  checking for NOTIFICATION_DAEMON... yes
  checking for NOTIFICATION_CAPPLET... configure: error: Package requirements
(glib-2.0 >= 2.10.0 gtk+-2.0 >= 2.10.0 libglade-2.0 gconf-2.0 libnotify dbus-1
dbus-glib-1) were not met:

  No package 'libnotify' found
* notification-daemon-xfce compiles fine without libnotify installed
  checking for optional package libnotify >= 0.4.0... not found


-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list