[SM-Grimoire-Bugs] [Bug 15078] New: kdelibs4 requires pcre

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Thu Feb 12 19:32:34 EST 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15078

           Summary: kdelibs4 requires pcre
           Product: Codex
           Version: stable grimoire
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P3
         Component: kde4
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org



Eric Sandall <sandalle at sourcemage.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
               Flag|                            |fixed_in_lesser_branch+


pcre is no longer optional for kdelibs4.

kdelibs4: Now requires pcre

    -- checking for module 'libpcre'
    --   package 'libpcre' not found
    -- Could NOT find PCRE  (missing:  PCRE_INCLUDE_DIR PCRE_PCRE_LIBRARY
    PCRE_PCREPOSIX_LIBRARY)
    CMake Error at kjs/CMakeLists.txt:69 (message):
      The PCRE regular expression library has not been found.  KJS requires
    PCRE
      >= 4.5 to function properly.  If you for some reason can not install
      >it,
      you can force a build with POSIX regex.h by passing
      -DKJS_FORCE_DISABLE_PCRE=true to cmake.  However, be advised that
    it'll
      result in many websites breaking

This also affects kdelibs4 4.1.3 in stable-0.29, as well as test and
stable-rc-0.30.


-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list