[SM-Grimoire-Bugs] [Bug 15065] New: cups 1.3.9 fails to compile using 2.6.28 sanitized headers

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Feb 6 03:00:11 EST 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15065

           Summary: cups 1.3.9 fails to compile using 2.6.28 sanitized
                    headers
           Product: Codex
           Version: stable grimoire
          Platform: x86-64
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: P3
         Component: printer
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org
            Blocks: 15061


Ever since building glibc against 2.6.28 using sanitized headers, hal has been
failing (and I assume it's linked).

$ sorcery -v
1.14.2

Architectures: x86_64 (seems to work on x86)

cflags: -march=nocona -fPIC -DPIC -pipe -DPIC -fPIC -O3 -Wall -Wchar-subscripts
-Wmissing-declarations -Wnested-externs -Wpointer-arith -Wcast-align
-Wsign-compare                                                                  

ldflags: -Wl,--as-needed -lz -z combreloc -s -Wl,-O1

/etc/sorcery/local/depends/glibc.p:
GLIBC_HEADERS_DIR="/usr/src/glibc-2.9/linux-2.6.28"

# cast cups
Computing previously installed dependencies...
cups preparing environment...
[[ which version? -> 'stable' ]]
cups running configuration...
[[ Do you want to build extra languages? -> n ]]
Install init script cups? [y]
Enable init script cups? [n]
Install xinetd script cups-lpd? [n]
cups checking dependencies...
cups has a dependency on zlib
cups has a dependency on jpeg
cups has a dependency on tiff
cups has a dependency on libpng
cups has a dependency on g++
cups has a dependency on pkgconfig
cups has an optional dependency on libusb (usb printers)
Do you want to use libusb? [y]
cups has an optional dependency on dbus (hardware notifications)
Do you want to use dbus? [y]
cups has an optional dependency on linux-pam (for pluggable authentication)
Do you want to use linux-pam? [y]
cups has an optional dependency on gnutls (use GNU TLS for SSL/TLS support)
Do you want to use gnutls? [y]
cups has an optional dependency on openldap (LDAP support)
Do you want to use openldap? [y]
cups has an optional dependency on openssl (for encrypted communications)
Do you want to use openssl? [y]
cups has an optional dependency on acl (for file system access control lists
support)
Do you want to use acl? [y]
cups has an optional dependency on openslp (to use the Service Location
Protocol for discovery)
Do you want to use openslp? [y]
cups has a suggested dependency on ghostscript (to print Postscript files)
Do you want to use ghostscript? [y]
...
Linking scsi...
Compiling serial.c...
In file included from serial.c:77:
/usr/include/linux/serial.h:164: error: expected specifier-qualifier-list
before '__u32'
make[1]: *** [serial.o] Error 1
make: *** [all] Error 1

Compiling with GLIBC_HEADERS_DIR="/usr/src/glibc-2.9/linux-2.6.27" sanitized
headers compiles fine.


-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list