[SM-Grimoire-Bugs] [Bug 15061] New: Packages fail to compile using 2.6.28 sanitized headers [MASTER]

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Feb 6 02:58:43 EST 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15061

           Summary: Packages fail to compile using 2.6.28 sanitized headers
                    [MASTER]
           Product: Codex
           Version: stable grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: kernels
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org


The blocking bugs mark packages which fail with 2.6.28 sanitized headers in
glibc.

General information:
Ever since building glibc against 2.6.28 using sanitized headers, hal has been
failing (and I assume it's linked).

$ sorcery -v
1.14.2

Architectures: x86 (two machines) and x86_64 (two machines)

cflags: -march=nocona -fPIC -DPIC -pipe -DPIC -fPIC -O3
ldflags: -Wl,--as-needed -lz -z combreloc -s -Wl,-O1

These packages break on machines with the following:
/etc/sorcery/local/depends/glibc.p:
GLIBC_HEADERS_DIR="/usr/src/glibc-2.9/linux-2.6.28"

These packages work on machines with the following:
/etc/sorcery/local/depends/glibc.p:
GLIBC_HEADERS_DIR="/usr/src/glibc-2.9/linux-2.6.27"


-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list