[SM-Grimoire-Bugs] [Bug 15537] New: thunderbird 2.0.0.23 fails to compile with GCC 4.4

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Mon Dec 21 19:47:31 EST 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15537

           Summary: thunderbird 2.0.0.23 fails to compile with GCC 4.4
           Product: Codex
           Version: devel grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: mail
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org
            Blocks: 15252


$ sorcery -v
1.14.4

$ gaze version gcc g++ thunderbird
Grimoire  Section  Spell        Grimoire Version  Installed Version
--------  -------  -----        ----------------  -----------------
test      gnu      gcc          4.4.2             4.4.2
test      gnu      g++          4.4.2             4.4.2
test      mail     thunderbird  2.0.0.23          2.0.0.23

# cast thunderbird
...
nsStackFrameUnix.cpp
c++ -o nsStackFrameUnix.o -c  -DMOZ_UPDATER -DMOZILLA_INTERNAL_API
-DOSTYPE=\"Li
nux2.6.32\" -DOSARCH=\"Linux\" -DBUILD_ID=0000000000 -DOS_TARGET=\"Linux\"
-DTAR
GET_XPCOM_ABI=\"x86_64-gcc3\" -DTARGET_OS_ABI=\"Linux_x86_64-gcc3\" 
-DTOOLKIT_E
M_VERSION=\"1.8.1.23\" -I../../widget/src/xremoteclient -I.
-I../../xpfe/bootstr
ap -I./../profile/src -I../../config  -I../../dist/include/appcomps
-I../../dist
/include/toolkitcomps -I../../dist/include/appshell
-I../../dist/include/appstar
tup -I../../dist/include/chrome -I../../dist/include/content
-I../../dist/includ
e/docshell -I../../dist/include/dom -I../../dist/include/embed_base
-I../../dist
/include/embedcomponents -I../../dist/include/extensions
-I../../dist/include/gf
x -I../../dist/include/intl -I../../dist/include/js -I../../dist/include/necko
-
I../../dist/include/pref -I../../dist/include/profile
-I../../dist/include/shell
service -I../../dist/include/string -I../../dist/include/uriloader
-I../../dist/
include/widget -I../../dist/include/windowwatcher -I../../dist/include/xpcom
-I.
./../dist/include/xpconnect -I../../dist/include/xpinstall
-I../../dist/include/
xremoteservice -I../../dist/include/xulapp -I../../dist/include
-I/usr/include/n
spr    -I../../dist/sdk/include    -fPIC   -fno-rtti -fno-exceptions -Wall
-Wcon
version -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor
-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic -march=core2 -fPIC
-DPIC
 -pipe -DPIC -fPIC -O2 -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED
-march=c
ore2 -fPIC -DPIC -pipe -DPIC -fPIC -O2 -I/usr/include/gtk-2.0
-I/usr/lib/gtk-2.0
/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0
-I
/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1
-I/usr/include/freetype2 -I/usr/include/libpng12     -DMOZILLA_CLIENT -include
../../mozilla-config.h -Wp,-MD,.deps/nsStackFrameUnix.pp nsStackFrameUnix.cpp
nsAppRunner.cpp:1373:6: error: #elif with no expression
...
nsAppRunner.cpp
c++ -o nsAppRunner.o -c  -DMOZ_UPDATER -DMOZILLA_INTERNAL_API
-DOSTYPE=\"Linux2.
6.32\" -DOSARCH=\"Linux\" -DBUILD_ID=0000000000 -DOS_TARGET=\"Linux\"
-DTARGET_X
PCOM_ABI=\"x86_64-gcc3\" -DTARGET_OS_ABI=\"Linux_x86_64-gcc3\" 
-DTOOLKIT_EM_VER
SION=\"1.8.1.23\" -I../../widget/src/xremoteclient -I. -I../../xpfe/bootstrap
-I
./../profile/src -I../../config  -I../../dist/include/appcomps
-I../../dist/incl
ude/toolkitcomps -I../../dist/include/appshell -I../../dist/include/appstartup
-
I../../dist/include/chrome -I../../dist/include/content
-I../../dist/include/doc
shell -I../../dist/include/dom -I../../dist/include/embed_base
-I../../dist/incl
ude/embedcomponents -I../../dist/include/extensions -I../../dist/include/gfx
-I.
./../dist/include/intl -I../../dist/include/js -I../../dist/include/necko
-I../.
./dist/include/pref -I../../dist/include/profile
-I../../dist/include/shellservi
ce -I../../dist/include/string -I../../dist/include/uriloader
-I../../dist/inclu
de/widget -I../../dist/include/windowwatcher -I../../dist/include/xpcom
-I../../
dist/include/xpconnect -I../../dist/include/xpinstall
-I../../dist/include/xremo
teservice -I../../dist/include/xulapp -I../../dist/include -I/usr/include/nspr  
  -I../../dist/sdk/include    -fPIC   -fno-rtti -fno-exceptions -Wall
-Wconversi
on -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-priv
acy -Wno-non-virtual-dtor -Wno-long-long -pedantic -march=core2 -fPIC -DPIC
-pip
e -DPIC -fPIC -O2 -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -march=core2 
-fPIC -DPIC -pipe -DPIC -fPIC -O2 -I/usr/include/gtk-2.0
-I/usr/lib/gtk-2.0/incl
ude -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0
-I/usr/
include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1
-I/usr/include/freetype2 -I/usr/include/libpng12     -DMOZILLA_CLIENT -include
../../mozilla-config.h -Wp,-MD,.deps/nsAppRunner.pp nsAppRunner.cpp
nsAppRunner.cpp:1373:6: error: #elif with no expression
In file included from ../../dist/include/string/nsStringIterator.h:43,
                 from ../../dist/include/string/nsAString.h:47,
                 from ../../dist/include/string/nsReadableUtils.h:49,
                 from ../../dist/include/necko/nsNetUtil.h:46,
                 from nsAppRunner.cpp:112
...

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list