[SM-Grimoire-Bugs] [Bug 15518] udev 149 (and probably some older versions) is looking for linux/bsg.h but doesn't find it.

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Sat Dec 19 00:40:34 EST 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15518


Eric Sandall <sandalle at sourcemage.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |sandalle at sourcemage.org




--- Comment #1 from Eric Sandall <sandalle at sourcemage.org>  2009-12-18 23:40:33 ---
Our glibc package provides the linux headers:
$ gaze from linux/bsg.h
glibc-2.10.1:/usr/include/linux/bsg.h
glibc-2.11:/usr/include/linux/bsg.h

What options do you have in /etc/sorcery/local/depends/glibc.p? I have:
GLIBC_NPTL="y"
GLIBC_USEIDN="y"
GLIBC_NOLIB64="y"
GLIBC_HEADERS_DIR="/usr/src/glibc-2.11/linux-2.6.31"
GLIBC_ARCH="x86_64"
GLIBC_CVS="n"
GLIBC_SANITIZE_HEADERS="n"
INIT_INSTALLED="nscd"
INIT_NOT_INSTALLED=""
INIT_ENABLED="nscd"
INIT_DISABLED=""

This means my glibc (and the rest of my system) was built with the 2.6.31 Linux
kernel headers, the ones provided by linux-2.6.31.tar.bz2 from kernel.org. If I
had GLIBC_SANITIZE_HEADERS="y" then it will use the headers from whatever linux
kernel you have installed with our linux package.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list