[SM-Grimoire-Bugs] [Bug 15518] New: udev 149 (and probably some older versions) is looking for linux/bsg.h but doesn't find it.

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Dec 18 23:34:05 EST 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15518

           Summary: udev 149 (and probably some older versions) is looking
                    for linux/bsg.h but doesn't find it.
           Product: Codex
           Version: test grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: disk
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: jaffa225man at linuxmail.org


Please excuse me if this bug report is filed incorrectly; it has been quite a
while since I filled one out.  I was trying to compile the latest udev spell
today, and had an issue fairly early on (listed below).  First I tried updating
to the latest kernel, which didn't fix it.  This bug may have more to do with
something the linux spell should do.  I found a similar bug report from gentoo
(http://bugs.gentoo.org/show_bug.cgi?format=multiple&id=292922).  Their fix was
to add linux-headers as a dependency, but I don't believe sourcemage has that
or any spell to take its place.  I did find the file in question (bsg.h) in
/usr/src/linux-2.6.32/include/linux/.  My temporary fix was to just symlink it
to /usr/include/linux, which seems to have worked fine.  This is what casting
udev (version 149) reported before the symlink solution:

  CC     extras/fstab_import/fstab_import.o
  CCLD   extras/fstab_import/fstab_import
  CC     extras/scsi_id/scsi_id.o
  CC     extras/scsi_id/scsi_serial.o
extras/scsi_id/scsi_serial.c:31:23: error: linux/bsg.h: No such file or
directory
extras/scsi_id/scsi_serial.c:160: warning: 'struct sg_io_v4' declared inside
parameter list
extras/scsi_id/scsi_serial.c:160: warning: its scope is only this definition or
declaration, which is probably not what you want
extras/scsi_id/scsi_serial.c: In function 'sg_err_category4':
extras/scsi_id/scsi_serial.c:162: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c:163: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c:163: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c:164: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c:165: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c: At top level:
extras/scsi_id/scsi_serial.c:290: warning: 'struct sg_io_v4' declared inside
parameter list
extras/scsi_id/scsi_serial.c: In function 'scsi_dump_v4':
extras/scsi_id/scsi_serial.c:292: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c:292: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c:293: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c:301: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c:301: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c:301: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c:304: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c:305: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c:306: error: dereferencing pointer to incomplete
type
extras/scsi_id/scsi_serial.c: In function 'scsi_inquiry':
extras/scsi_id/scsi_serial.c:332: error: storage size of 'io_v4' isn't known
extras/scsi_id/scsi_serial.c:334: error: invalid application of 'sizeof' to
incomplete type 'struct sg_io_v4' 
extras/scsi_id/scsi_serial.c:336: error: 'BSG_PROTOCOL_SCSI' undeclared (first
use in this function)
extras/scsi_id/scsi_serial.c:336: error: (Each undeclared identifier is
reported only once
extras/scsi_id/scsi_serial.c:336: error: for each function it appears in.)
extras/scsi_id/scsi_serial.c:337: error: 'BSG_SUB_PROTOCOL_SCSI_CMD' undeclared
(first use in this function)
make[2]: *** [extras/scsi_id/scsi_serial.o] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
 ! Problem Detected ! 

Is the linux spell supposed to install headers?  It didn't for me.  Or is it
that udev is supposed to be pointed to /usr/src/linux/include/linux ?  Thanks
for any insight into the matter.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list