[SM-Grimoire-Bugs] [Bug 15517] New: libvirt 0.7.x requires all lvm tools

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Dec 18 05:50:31 EST 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15517

           Summary: libvirt 0.7.x requires all lvm tools
           Product: Codex
           Version: stable grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: libs
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org


sorcery -v
1.14.4

$ gaze version lvm libvirt
Grimoire  Section  Spell    Grimoire Version  Installed Version
--------  -------  -----    ----------------  -----------------
test      disk     lvm      2.02.56           2.02.56
test      libs     libvirt  0.7.4             0.4.6

==> /etc/sorcery/local/depends/lvm.p <==
LVM_DM_ONLY="y"
LVM_OPTS=""

# cast libvirt
...
[[ Build mpath storage backend -> y ]]
[[ Build FileSystem storage backend -> y ]]
[[ Build virtual network driver -> y ]]
[[ Build with QEMU/KVM support -> y ]]
[[ Build with VMWare ESX/GSX support -> y ]]
[[ Build Linux Containers(lxc) support -> y ]]
[[ Build VirtualBox support -> y ]]
[[ Build User Mode Linux support -> y ]]
[[ Build remote driver support? -> y ]]
[[ Build libvirtd support? -> y ]]
Install init script libvirtd? [y]
Enable init script libvirtd? [y]
...
libvirt has a disabled optional dependency on avahi
libvirt has an optional dependency on some LIBSASL (for Cyrus SASL
authentication support).
Continue to use cyrus-sasl? [y]
libvirt has an enabled optional dependency on gettext
libvirt has an enabled optional dependency on iptables
libvirt has an optional dependency on xen-tools (for Xen support)
Do you want to cast xen-tools? [n]
libvirt has an enabled optional dependency on parted
libvirt has an optional dependency on hal (HAL support)
Do you want to use hal? [y]
libvirt has an optional dependency on devicekit (DeviceKit support)
Do you want to use devicekit? [y]
libvirt has an enabled optional dependency on python
libvirt has an optional dependency on policykit (PolicyKit support)
Do you want to use policykit? [y]
libvirt has an optional dependency on libssh2 (SSH2 support)
Do you want to cast libssh2? [n]
libvirt has a suggested dependency on nc (for remote SSH tunneling)
Do you want to use nc? [y]
Python bindings requested, forcing python dependency
...
checking for showmount... /usr/sbin/showmount
checking for pvcreate... no
checking for vgcreate... no
checking for lvcreate... no
checking for pvremove... no
checking for vgremove... no
checking for lvremove... no
checking for vgchange... no
checking for vgscan... no
checking for pvs... no
checking for vgs... no
checking for lvs... no
configure: error: We need pvcreate for LVM storage driver

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list