[SM-Grimoire-Bugs] [Bug 13111] gnome-mount doesn't work

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Sat Aug 29 12:07:00 EDT 2009


http://bugs.sourcemage.org/show_bug.cgi?id=13111


David Brown <dmlb2000 at gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |WORKSFORME




--- Comment #4 from David Brown <dmlb2000 at gmail.com>  2009-08-29 11:06:58 ---
Okay so now that everything is managed by PolicyKit you need to run a few
commands to fix this issue.

dmlb2000 at uber-gamer:~$ sudo polkit-action --set-defaults-inactive
org.freedesktop.hal.storage.mount-removable yes
dmlb2000 at uber-gamer:~$ sudo polkit-action --set-defaults-any
org.freedesktop.hal.storage.mount-removable yes
dmlb2000 at uber-gamer:~$ polkit-action --action
org.freedesktop.hal.storage.mount-removable
action_id:        org.freedesktop.hal.storage.mount-removable
description:      Mount file systems from removable drives.
message:          System policy prevents mounting removable media
default_any:      yes (factory default: no)
default_inactive: yes (factory default: no)
default_active:   yes
dmlb2000 at uber-gamer:~$ gnome-mount -tvd /dev/cdrom gnome-mount 0.8
Resolved device file /dev/cdrom -> /dev/sr0
** (gnome-mount:761): DEBUG: Mounting
/org/freedesktop/Hal/devices/volume_label_Ubuntu_6_10_i386
** (gnome-mount:761): DEBUG: read default option 'uid=' from gconf strlist key
/system/storage/default_options/iso9660/mount_options
** (gnome-mount:761): DEBUG: Mounting
/org/freedesktop/Hal/devices/volume_label_Ubuntu_6_10_i386 with
mount_point='Ubuntu 6.10 i386', fstype='', num_options=1
** (gnome-mount:761): DEBUG:   option='uid=1000'
Mounted /dev/sr0 at "/media/Ubuntu 6.10 i386"
dmlb2000 at uber-gamer:~$ mount
/dev/mapper/vg0-smgl on / type ext4 (rw)
/dev/mapper/vg0-home on /home type ext4 (rw)
/dev/sda1 on /boot type ext3 (rw)
devpts on /dev/pts type devpts (rw)
none on /proc type proc (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
gvfs-fuse-daemon on /home/dmlb2000/.gvfs type fuse.gvfs-fuse-daemon
(rw,nosuid,nodev,user=dmlb2000)
/dev/sr0 on /media/Ubuntu 6.10 i386 type iso9660 (ro,nosuid,nodev,uid=1000)
dmlb2000 at uber-gamer:~$

So not sure what you do if PolicyKit isn't installed but there's an answer.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list