[SM-Grimoire-Bugs] [Bug 15104] libxcb 1.2 renames shared objects and loses the library archive breaking many packages

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Aug 14 00:41:58 EDT 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15104





--- Comment #31 from Eric Sandall <sandalle at sourcemage.org>  2009-08-13 23:41:58 ---
(In reply to comment #30)
> Here's the current error for gtk+2 in devel-xorg-modular:
> checking pkg-config is at least version 0.9.0... yes
> checking for BASE_DEPENDENCIES... configure: error: Package requirements
> (glib-2.0 >= 2.19.7    atk >= 1.13.0    pango >= 1.20    cairo >= 1.6) were not
> met:
> 
> Package xcb-renderutil was not found in the pkg-config search path.
> Perhaps you should add the directory containing `xcb-renderutil.pc'
> to the PKG_CONFIG_PATH environment variable
> Package 'xcb-renderutil', required by 'cairo', not found

For some reason gtk+2 isn't registered as depending directly on cairo:
$ gaze depends cairo 1
cairomm depends on cairo (required)
dasher depends on cairo (required)
emerald depends on cairo (required)
evas depends on cairo (optional)
evince depends on cairo (required)
firefox depends on cairo (required)
gegl depends on cairo (optional)
ghostscript depends on cairo (optional)
gnaural depends on cairo (required)
gnome-panel depends on cairo (required)
gst-plugins-good depends on cairo (optional)
libgdiplus depends on cairo (required)
librsvg2 depends on cairo (required)
metacity depends on cairo (required)
pango depends on cairo (required)
pangomm depends on cairo (required)
perl-cairo depends on cairo (required)
poppler depends on cairo (optional)
pycairo depends on cairo (required)
thunderbird depends on cairo (optional)
xulrunner depends on cairo (required)

Nothing at all seems to link cairo to gtk+2:
$ gaze depends cairo|grep gtk+2|wc -l
0

Nor even the other way around, nothing linking gtk+2 to cairo:
$ gaze depends gtk+2|grep "^cairo"
cairo depends on fontconfig (required)
cairo depends on ghostscript (required)
cairo depends on glitz (optional)
cairo depends on libpng (optional)
cairo depends on librsvg2 (optional)
cairo depends on libx11 (required)
cairo depends on libxcb (optional)
cairo depends on libxrender (optional)
cairo depends on poppler (required)
cairo depends on xcb-util (optional)
cairomm depends on cairo (required)

I have the above issue on three of my machines, but one of my machines seems to
have it working:
$ gaze depends cairo 1
firefox depends on cairo (required)
gegl depends on cairo (optional)
ghostscript depends on cairo (optional)
gnome-panel depends on cairo (required)
gtk+2 depends on cairo (required)
libgdiplus depends on cairo (required)
librsvg2 depends on cairo (required)
pango depends on cairo (required)
poppler depends on cairo (optional)
pycairo depends on cairo (required)
xulrunner depends on cairo (required)

So looks like an issue with my boxes and not a bug, hopefully. :) With the
correct dependencies the existing triggers should work.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list