[SM-Grimoire-Bugs] [Bug 14229] circular depenency between glib2 and pkgconfig

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Sat Sep 27 13:34:40 EDT 2008


http://bugs.sourcemage.org/show_bug.cgi?id=14229


Andrew Stitt <acedit at armory.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |acedit at armory.com
             Status|NEW                         |RESOLVED
         Resolution|                            |FIXED




--- Comment #7 from Andrew Stitt <acedit at armory.com>  2008-09-27 12:34:39 ---
quickfix db12af7358430c97db164a5769c2f68604a7855c only allows pkgconfig
dependency if glib2 is installed. comment added so when sorcery supports
detecting and automatically breaking/repairing of cycles the check can be
removed.

I recommend using this simple workaround whenever a cycle is noticed elsewhere
in the grimoire. Users can be encouraged to perform a rebuild after their
system is functional to pull in these additional optional dependencies. Please
include an identifiable comment so these issues can be easily tracked and
hopefully rectified in the future. 


-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list