[SM-Grimoire-Bugs] [Bug 14919] New: virtualbox starts only with root privileges

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Nov 28 14:22:10 EST 2008


http://bugs.sourcemage.org/show_bug.cgi?id=14919

           Summary: virtualbox starts only with root privileges
           Product: Codex
           Version: test grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: utils
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: bustervill at yahoo.com


When virtualbox is started as a non-root user this error appears:

OK, vboxdrv is loaded.
OK, VBoxSVC is running.
OK, VirtualBox is starting ...
VirtualBox: Error -10 in SUPR3HardenedMain!
VirtualBox: Effective UID is not root (euid=1000 egid=1000 uid=1000 gid=1000)

VirtualBox: Tip! It may help to reinstall VirtualBox.

Turns out that this is some security feature in the 2.x.x series. To be able to
run it as a regular user, virtualbox must be compiled with
'--disable-hardening' flag. Could the flag be added to the spell?
There is some discussion in this thread:
http://bbs.archlinux.org/viewtopic.php?id=55406&p=3 Post #67 say that some more
actions must be performed in order to get this thing going.


-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list