[SM-Grimoire-Bugs] [Bug 14762] mplayer & ffmpeg doesn't build with x264

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Nov 21 08:55:35 EST 2008


http://bugs.sourcemage.org/show_bug.cgi?id=14762


Vasil Yonkov <bustervill at yahoo.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|mplayer doesn't build with  |mplayer & ffmpeg doesn't
                   |x264                        |build with x264




--- Comment #2 from Vasil Yonkov <bustervill at yahoo.com>  2008-11-21 07:55:35 ---
ffmpeg also fails to build with x264:

In file included from x264.c:22:
avcodec.h:2433: warning: 'ImgReSampleContext' is deprecated
avcodec.h:2436: warning: 'ImgReSampleContext' is deprecated
x264.c: In function 'X264_init':
x264.c:165: error: 'x264_param_t' has no member named 'b_bframe_adaptive'
x264.c:228: error: 'struct <anonymous>' has no member named 'b_bidir_me'
x264.c:229: error: 'struct <anonymous>' has no member named 'b_bframe_rdo'
x264.c:254: error: 'struct <anonymous>' has no member named 'psz_rc_eq'
make[1]: Leaving directory `/usr/src/ffmpeg-20070219/libavcodec'
make[1]: *** [x264.o] Error 1
make: *** [lib] Error 2
 ! Problem Detected !


-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list