[SM-Grimoire-Bugs] [Bug 14872] GTK+2 has unfulfilled dependency on Pango

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Nov 14 04:13:18 EST 2008


http://bugs.sourcemage.org/show_bug.cgi?id=14872


Vasil Yonkov <bustervill at yahoo.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |bustervill at yahoo.com




--- Comment #1 from Vasil Yonkov <bustervill at yahoo.com>  2008-11-14 03:13:17 ---
This happens on first build of Pango, Cairo & GTK+2, when there aren't previous
installations of them on the system. GTK+2 requires pangocairo (Cairo & Pango
installed), Pango depends on Cairo and Cairo must be with PDF & PS (GTK+2
requires that), so every dependencies of Pango & Cairo must be build first,
then build GTK+2. Yeah, but if any of those Pango & Cairo dependencies have
enabled optional dependency on GTK+2, then turns out that GTK+2 must be build
before them, which is impossible. It's tricky.
At this point "cast" does not provide any assistance warning the user of this
kinds of traps. The solution is to build Cairo only with PS & PDF, then build
Pango, then build GTK+2 and finally rebuild Cairo with all optional
dependencies you want.
The same applies to this bug http://bugs.sourcemage.org/show_bug.cgi?id=14873


-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list