[SM-Grimoire-Bugs] [Bug 14350] New: poppler needs QTTEST, ... if optionally depends on qt4

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Mon Mar 3 05:33:34 EST 2008


http://bugs.sourcemage.org/show_bug.cgi?id=14350

           Summary: poppler needs QTTEST, ... if optionally depends on qt4
           Product: Codex
           Version: test grimoire
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: graphics-libs
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: hgr at vabo.cz


checking for Qt headers... /usr/include/qt
checking for Qt libraries... /usr/lib
checking if Qt needs -pthread... no
checking for POPPLER_QT4... configure: error: Package requirements (QtCore >=
4.1.0 QtGui >= 4.1.0 QtXml >= 4.1.0 QtTest >= 4.1.0) were not met:

No package 'QtTest' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables POPPLER_QT4_CFLAGS
and POPPLER_QT4_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

 ! Problem Detected !
Creating compile log /var/log/sorcery/compile/poppler-0.6.4.bz2
View Compile log for poppler-0.6.4? [n]

Spells that encountered problems:
---------------------------------
poppler


----------------------------------------------------------------
Without optional_depends qt4 "cast poppler" is OK.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the SM-Grimoire-Bugs mailing list